summary refs log tree commit diff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm39
1 files changed, 26 insertions, 13 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 57dd5b9c2f..c4d0662e99 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -32,7 +32,9 @@
   #:use-module (gnu packages glib)
   #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages pkg-config)
-  #:use-module (gnu packages qt))
+  #:use-module (gnu packages polkit)
+  #:use-module (gnu packages qt)
+  #:use-module (gnu packages xorg))
 
 (define-public libqtxdg
   (package
@@ -72,29 +74,40 @@ in Qt.")
 (define-public liblxqt
   (package
     (name "liblxqt")
-    (version "0.9.0")
+    (version "0.13.0")
     (source
      (origin
        (method url-fetch)
-       (uri
-         (string-append "https://github.com/lxde/" name
-                        "/archive/" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (uri (string-append
+             "https://github.com/lxqt/" name "/releases/download/"
+             version "/" name "-" version ".tar.xz"))
        (sha256
-        (base32
-         "0mbl3qc0yfgfsndqrw8vg8k5irsy0pg2wrad8nwv0aphphd4n7rg"))
-       (patches (search-patches "liblxqt-include.patch"))))
+        (base32 "0fba0nq5b9fvvmklcikcd4nwhzlp5d6k1q1f80r34kncdzfvj7dl"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f))
-    (native-inputs `(("pkg-config" ,pkg-config)))
+     `(#:tests? #f                      ; no tests
+       #:configure-flags
+       ;; TODO: prefetch translations files from 'lxqt-l10n'.
+       '("-DPULL_TRANSLATIONS=NO")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-source
+           (lambda _
+             (substitute* "CMakeLists.txt"
+               (("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
+                "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/polkit-1/actions"))
+             #t)))))
     (inputs
      `(("kwindowsystem" ,kwindowsystem)
        ("libqtxdg" ,libqtxdg)
-       ("qtbase" ,qtbase)
+       ("libxscrnsaver" ,libxscrnsaver)
+       ("polkit-qt" ,polkit-qt)
+       ("qtsvg" ,qtsvg)
        ("qttools" ,qttools)
        ("qtx11extras" ,qtx11extras)))
-    (home-page "http://lxqt.org/")
+    (native-inputs
+     `(("lxqt-build-tools" ,lxqt-build-tools)))
+    (home-page "https://lxqt.org/")
     (synopsis "Core utility library for all LXQt components")
     (description "liblxqt provides the basic libraries shared by the
 components of the LXQt desktop environment.")