summary refs log tree commit diff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm140
1 files changed, 70 insertions, 70 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 587a400d33..18d5c26ce0 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1399,7 +1399,7 @@ between different versions of ØMQ.")
 (define-public cppzmq
   (package
     (name "cppzmq")
-    (version "4.8.1")
+    (version "4.10.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1407,7 +1407,7 @@ between different versions of ØMQ.")
                     (commit (string-append "v" version))))
               (sha256
                (base32
-                "0zzq20wzk5grshxfqhqgqqfwb38w3k83r821isvyaxghsglpwks3"))
+                "1074316b2n2sbvamnnm8c0p9s0xw2m0g84i9pac02vqbaxbmldqx"))
               (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
@@ -1426,7 +1426,7 @@ files contain direct mappings of the abstractions provided by the ØMQ C API.")
 (define-public libnatpmp
   (package
     (name "libnatpmp")
-    (version "20150609")
+    (version "20230423")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -1434,7 +1434,7 @@ files contain direct mappings of the abstractions provided by the ØMQ C API.")
                     name "-" version ".tar.gz"))
               (sha256
                (base32
-                "1c1n8n7mp0amsd6vkz32n8zj3vnsckv308bb7na0dg0r8969rap1"))))
+                "0w7wvf4yi8qv659dg9d3ndqvh3bqhgm21gd135spwhq6hhnfv106"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -1710,7 +1710,7 @@ and up to 1 Mbit/s downstream.")
 (define-public whois
   (package
     (name "whois")
-    (version "5.5.11")
+    (version "5.5.17")
     (source
      (origin
        (method git-fetch)
@@ -1719,26 +1719,28 @@ and up to 1 Mbit/s downstream.")
               (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0wys0aixzq6mzvg7p6jb0d5rkkg23pjcgcsx86p7hjidxdvnbwzr"))))
+        (base32 "1mqgc8saz4l0hr4p8r9cgndwx3r9aal7ak9irgrrkxyjd65xpa9n"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ; no test suite
-       #:make-flags (list (string-append "CC=" ,(cc-for-target))
-                          (string-append "PKG_CONFIG=" ,(pkg-config-for-target))
-                          (string-append "prefix=" (assoc-ref %outputs "out")))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)            ; no configure script
-         (add-before 'build 'setenv
-           (lambda _
-             (setenv "HAVE_ICONV" "1")
-             #t)))))
+     (list
+      #:tests? #f                       ; no test suite
+      #:make-flags
+      #~(list (string-append "CC=" #$(cc-for-target))
+              (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
+              (string-append "prefix=" #$output)
+              "BASHCOMPDIR=$(prefix)/share/bash-completion/completions")
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)           ; no configure script
+          (add-before 'build 'setenv
+            (lambda _
+              (setenv "HAVE_ICONV" "1"))))))
     (inputs
      (list libidn2))
     (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("perl" ,perl)
-       ("pkg-config" ,pkg-config)))
+     (list gettext-minimal
+           perl
+           pkg-config))
     (synopsis "Intelligent client for the WHOIS directory service")
     (description
       "whois searches for an object in a @dfn{WHOIS} (RFC 3912) database.
@@ -1755,14 +1757,14 @@ of the same name.")
 (define-public wireshark
   (package
     (name "wireshark")
-    (version "4.0.5")
+    (version "4.0.7")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.wireshark.org/download/src/wireshark-"
                            version ".tar.xz"))
        (sha256
-        (base32 "0abb36n3li5w22f435k31mvk0sy0f41sxz4fqrl4ksjzjd377dki"))))
+        (base32 "0xw7iagh37y02qgzgmb2xf1qagbphv5lpgra8lq3x0pzrc27p7x7"))))
     (build-system cmake-build-system)
     (arguments
      (list
@@ -2679,7 +2681,7 @@ that block port 22.")
 (define-public iperf
   (package
     (name "iperf")
-    (version "3.13")
+    (version "3.14")
     (source
      (origin
        (method git-fetch)
@@ -2688,7 +2690,7 @@ that block port 22.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "19i0lkr2i4iyy9hr5iwxnhb8pmjrqsbwbnzky6agy9yzgzrggfjv"))))
+        (base32 "0xy7q508yrraa8q3bxdsc2fwacc6qm7l6p44a07jp7ki8bwdcs8z"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
@@ -2973,42 +2975,38 @@ enabled due to license conflicts between the BSD advertising clause and the GPL.
 (define-public spiped
   (package
     (name "spiped")
-    (version "1.6.1")
+    (version "1.6.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://www.tarsnap.com/spiped/spiped-"
                                   version ".tgz"))
               (sha256
                (base32
-                "04rpnc53whfky7pp2m9h35gwzwn6788pnl6c1qd576mpknbqjw4d"))))
+                "0rs5403bp48wyy2x0f3hk0f75ds1qn03sgyli2c7y7fi29ynim05"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:test-target "test"
-       #:make-flags (let* ((out (assoc-ref %outputs "out"))
-                           (bindir (string-append out "/bin"))
-                           (man1dir (string-append out "/share/man/man1")))
-                      (list ,(string-append "CC=" (cc-for-target)) ; It tries to invoke `c99`.
-                            (string-append "BINDIR=" bindir)
-                            (string-append "MAN1DIR=" man1dir)))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-command-invocations
-           (lambda _
-             (substitute* '("Makefile"
-                            "libcperciva/cpusupport/Build/cpusupport.sh"
-                            "libcperciva/POSIX/posix-cflags.sh"
-                            "libcperciva/POSIX/posix-l.sh")
-               (("command -p") ""))
-             #t))
-         (delete 'configure) ; No ./configure script.
-         (add-after 'install 'install-more-docs
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref %outputs "out"))
-                    (misc (string-append out "/share/doc/spiped")))
-               (install-file "DESIGN.md" misc)
-               #t))))))
+     (list
+      #:test-target "test"
+      #:make-flags
+      #~(list (string-append "CC=" #$(cc-for-target))
+              (string-append "BINDIR=" #$output "/bin")
+              (string-append "MAN1DIR=" #$output "/share/man/man1"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-command-invocations
+            (lambda _
+              (substitute* '("Makefile"
+                             "libcperciva/cpusupport/Build/cpusupport.sh"
+                             "libcperciva/POSIX/posix-cflags.sh"
+                             "libcperciva/POSIX/posix-l.sh")
+                (("command -p") ""))))
+          (delete 'configure)           ; no ./configure script
+          (add-after 'install 'install-more-docs
+            (lambda _
+              (install-file "DESIGN.md"
+                            (string-append #$output "/share/doc/spiped")))))))
     (native-inputs
-     (list procps)) ; `ps` is used by the test suite.
+     (list procps))                     ; `ps` is used by the test suite
     (inputs
      (list openssl))
     (home-page "https://www.tarsnap.com/spiped.html")
@@ -4201,7 +4199,7 @@ network.  This must be enabled on the target host, usually in the BIOS.")
 (define-public traceroute
   (package
     (name "traceroute")
-    (version "2.1.0")
+    (version "2.1.2")
     (source
      (origin
        (method url-fetch)
@@ -4209,26 +4207,28 @@ network.  This must be enabled on the target host, usually in the BIOS.")
                            "traceroute-" version "/traceroute-"
                            version ".tar.gz"))
        (sha256
-        (base32 "1dh32vcfawkl1p9g4ral1p0camds4paqr8db1kaqxwyk6hmd4s9n"))))
+        (base32 "07svkglyizxirgcmv6d4ih59f3ds8pnyprvkrqcf5d3p567jcz2h"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ;no test suite
-       #:make-flags
-       (list (string-append "LIBRARY_PATH="
-                            (assoc-ref %build-inputs "libc") "/lib")
-             (string-append "CFLAGS=-I"
-                            (assoc-ref %build-inputs "kernel-headers")
-                            "/include")
-             "LDFLAGS=-lm -L../libsupp"
-             (string-append "prefix=" (assoc-ref %outputs "out")))
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-make
-           (lambda _
-             (substitute* "default.rules"
-               ((" \\$\\(LIBDEPS\\)") "$(filter-out -l%,$(LIBDEPS))"))))
-         (delete 'bootstrap)            ;no configure.ac file
-         (delete 'configure))))         ;no configure script
+     (list
+      #:tests? #f                       ; no test suite
+      #:make-flags
+      #~(list (string-append "LIBRARY_PATH="
+                             (assoc-ref %build-inputs "libc") "/lib")
+              (string-append "CFLAGS=-I"
+                             (assoc-ref %build-inputs "kernel-headers")
+                             "/include")
+              "LDFLAGS=-lm -L../libsupp"
+              (string-append "prefix=" #$output))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'patch-make
+            (lambda _
+              (substitute* "default.rules"
+                ((" \\$\\(LIBDEPS\\)")
+                 "$(filter-out -l%,$(LIBDEPS))"))))
+          (delete 'bootstrap)           ; no configure.ac file
+          (delete 'configure))))        ; no configure script
     (home-page "https://traceroute.sourceforge.net/")
     (synopsis "Tracks the route taken by packets over an IP network")
     (description "This package provides a modern, but Linux-specific