summary refs log tree commit diff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm18
1 files changed, 0 insertions, 18 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5d8237d80a..ed868ea1f9 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2825,26 +2825,8 @@ OCaml with fibers.")
 make it easy to run normally-blocking I/O operations concurrently in a single
 process.  Also, in many cases, Lwt threads can interact without the need for
 locks or other synchronization primitives.")
-    (properties `((ocaml4.07-variant . ,(delay ocaml4.07-lwt))))
     (license license:lgpl2.1)))
 
-(define-public ocaml4.07-lwt
-  (package-with-ocaml4.07
-   (package
-     (inherit ocaml-lwt)
-     (name "ocaml-lwt")
-     (version "5.5.0")
-     (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-                (url "https://github.com/ocsigen/lwt")
-                (commit version)))
-         (file-name (git-file-name name version))
-         (sha256 (base32
-                  "1jbjz2rsz3j56k8vh5qlmm87hhkr250bs2m3dvpy9vsri8rkzj9z"))))
-     (properties '()))))
-
 ;; TODO this alias is not ideal but ocaml-lwt already explicitly specifies a
 ;; package argument and at least this way the importer doesn't try to
 ;; re-import it.