summary refs log tree commit diff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 8474904265..62f1e84a3b 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Clément Lassieur <clement@lassieur.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19,7 +20,9 @@
 
 (define-module (gnu packages openstack)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages ssh)
   #:use-module (gnu packages tls)
+  #:use-module (gnu packages version-control)
   #:use-module (guix build-system python)
   #:use-module (guix download)
   #:use-module ((guix licenses)
@@ -781,3 +784,49 @@ permanence.")
          ("python2-oslosphinx" ,python2-oslosphinx)
          ,@(fold alist-delete (package-native-inputs swiftclient)
             '("python-keystoneclient" "python-oslosphinx")))))))
+
+(define-public python-git-review
+  (package
+    (name "python-git-review")
+    (version "1.25.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "git-review" version))
+       (sha256
+        (base32
+         "07d1jn9ryff5j5ic6qj5pbk10m1ccmpllj0wyalrcms1q9yhlzh8"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:tests? #f ; tests require a running Gerrit server
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap-program
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (git (assoc-ref inputs "git"))
+                    (openssh (assoc-ref inputs "openssh")))
+               (wrap-program (string-append out "/bin/git-review")
+                 `("PATH" ":" prefix
+                   ,(map (lambda (dir)
+                           (string-append dir "/bin"))
+                         (list git openssh))))))))))
+    (native-inputs
+     `(("python-pbr" ,python-pbr)))
+    (inputs
+     `(("python-requests" ,python-requests)
+       ("git" ,git)
+       ("openssh" ,openssh)))
+    (home-page "http://docs.openstack.org/infra/git-review/")
+    (synopsis "Command-line tool for Gerrit")
+    (description
+     "Git-review is a command-line tool that helps submitting Git branches to
+Gerrit for review, or fetching existing ones.")
+    (license asl2.0)))
+
+(define-public python2-git-review
+  (let ((base (package-with-python2 (strip-python2-variant python-git-review))))
+    (package (inherit base)
+             (native-inputs
+              `(("python2-setuptools" ,python2-setuptools)
+                ,@(package-native-inputs base))))))