summary refs log tree commit diff
path: root/gnu/packages/patches/azr3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/azr3.patch')
-rw-r--r--gnu/packages/patches/azr3.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/patches/azr3.patch b/gnu/packages/patches/azr3.patch
index 5849383c5b..93e9b5b11a 100644
--- a/gnu/packages/patches/azr3.patch
+++ b/gnu/packages/patches/azr3.patch
@@ -68,9 +68,9 @@ The patch has been sent to the developer on 2016-09-26.
    Widget* eb = add_clickbox(m_fbox, 14, 319, 14, 44);
    eb->signal_button_press_event().
 -    connect(sigc::hide(bind(bind(mem_fun(*this, &AZR3GUI::change_mode), 
--				 ref(m_fbox)), false)));
+-				 sigc::ref(m_fbox)), false)));
 +    connect(sigc::hide(sigc::bind(sigc::mem_fun(*this, &AZR3GUI::change_mode), 
-+                                  false, std::ref(m_fbox))));
++                                  false, sigc::ref(m_fbox))));
    m_fx_widgets.push_back(eb);
    
    // Mr Valve controls
@@ -79,15 +79,15 @@ The patch has been sent to the developer on 2016-09-26.
    Widget* eb2 = add_clickbox(m_vbox, 14, 53, 14, 44);
    eb2->signal_button_press_event().
 -    connect(sigc::hide(bind(bind(mem_fun(*this, &AZR3GUI::change_mode), 
--				 ref(m_fbox)), true)));
+-				 sigc::ref(m_fbox)), true)));
 +    connect(sigc::hide(sigc::bind(sigc::mem_fun(*this, &AZR3GUI::change_mode), 
-+                                  true, std::ref(m_fbox))));
++                                  true, sigc::ref(m_fbox))));
  
    // vibrato controls
    add_switch(m_vbox, n_1_vibrato, 39, 17, Switch::Green);
 @@ -352,9 +352,9 @@
    knob->set_style(s);
-   if (port >= 0 && port < m_adj.size()) {
+   if (port < m_adj.size()) {
      knob->get_adjustment().signal_value_changed().
 -      connect(compose(bind<0>(mem_fun(*this, &AZR3GUI::control_changed), port),
 -		      mem_fun(knob->get_adjustment(), 
@@ -100,7 +100,7 @@ The patch has been sent to the developer on 2016-09-26.
    }
 @@ -382,8 +382,8 @@
    db->set_style(s);
-   if (port >= 0 && port < m_adj.size()) {
+   if (port < m_adj.size()) {
      db->get_adjustment().signal_value_changed().
 -      connect(compose(bind<0>(mem_fun(*this, &AZR3GUI::control_changed), port),
 -		      mem_fun(db->get_adjustment(), &Adjustment::get_value)));