summary refs log tree commit diff
path: root/gnu/packages/patches/emacs-exec-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/emacs-exec-path.patch')
-rw-r--r--gnu/packages/patches/emacs-exec-path.patch22
1 files changed, 10 insertions, 12 deletions
diff --git a/gnu/packages/patches/emacs-exec-path.patch b/gnu/packages/patches/emacs-exec-path.patch
index 884fa94a64..7303599df1 100644
--- a/gnu/packages/patches/emacs-exec-path.patch
+++ b/gnu/packages/patches/emacs-exec-path.patch
@@ -4,15 +4,13 @@ with things like GCC being referenced.
 
 --- a/lisp/loadup.el
 +++ b/lisp/loadup.el
-@@ -64,6 +64,11 @@
- 			    (expand-file-name "textmodes" dir)
- 			    (expand-file-name "vc" dir)))))
- 
-+;; Reset 'exec-path' so we don't capture the build-time $PATH in the
-+;; 'emacs' executable.
-+(setq-default exec-path nil)
-+(setq exec-path nil)
-+
- (if (eq t purify-flag)
-     ;; Hash consing saved around 11% of pure space in my tests.
-     (setq purify-flag (make-hash-table :test 'equal :size 70000)))
+@@ -481,7 +481,8 @@ lost after dumping")))
+                         ((equal dump-mode "dump") "emacs")
+                         ((equal dump-mode "bootstrap") "emacs")
+                         ((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp")
+-                        (t (error "unrecognized dump mode %s" dump-mode)))))
++                        (t (error "unrecognized dump mode %s" dump-mode))))
++          (exec-path nil))
+       (message "Dumping under the name %s" output)
+       (condition-case ()
+           (delete-file output)