summary refs log tree commit diff
path: root/gnu/packages/patches/icecat-bug-1248851.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/icecat-bug-1248851.patch')
-rw-r--r--gnu/packages/patches/icecat-bug-1248851.patch37
1 files changed, 0 insertions, 37 deletions
diff --git a/gnu/packages/patches/icecat-bug-1248851.patch b/gnu/packages/patches/icecat-bug-1248851.patch
deleted file mode 100644
index ea4d6831b5..0000000000
--- a/gnu/packages/patches/icecat-bug-1248851.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-Copied from upstream:
-https://hg.mozilla.org/releases/mozilla-esr38/raw-rev/8c1d40e45a72
-
-# HG changeset patch
-# User Xidorn Quan <quanxunzhen@gmail.com>
-# Date 1456199544 -28800
-# Node ID 8c1d40e45a72c6432e879137a0afa519dc6c9841
-# Parent  1dd0ca8e70bd77b6fd93f36cc4e9c2cebfe8ba0a
-Bug 1248851 - r=sicking, a=ritu
-
-diff --git a/dom/indexedDB/ActorsParent.cpp b/dom/indexedDB/ActorsParent.cpp
---- a/dom/indexedDB/ActorsParent.cpp
-+++ b/dom/indexedDB/ActorsParent.cpp
-@@ -14823,22 +14823,19 @@ ObjectStoreAddOrPutRequestOp::DoDatabase
-     }
- 
-     snappy::RawCompress(uncompressed, uncompressedLength, compressed,
-                         &compressedLength);
- 
-     uint8_t* dataBuffer = reinterpret_cast<uint8_t*>(compressed);
-     size_t dataBufferLength = compressedLength;
- 
--    // If this call succeeds, | compressed | is now owned by the statement, and
--    // we are no longer responsible for it.
-     rv = stmt->BindAdoptedBlobByName(NS_LITERAL_CSTRING("data"), dataBuffer,
-                                      dataBufferLength);
-     if (NS_WARN_IF(NS_FAILED(rv))) {
--      moz_free(compressed);
-       return rv;
-     }
-   }
- 
-   nsCOMPtr<nsIFile> fileDirectory;
-   nsCOMPtr<nsIFile> journalDirectory;
- 
-   if (mFileManager) {
-