summary refs log tree commit diff
path: root/gnu/packages/patches/openjdk-10-hotspot-stack-size.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/openjdk-10-hotspot-stack-size.patch')
-rw-r--r--gnu/packages/patches/openjdk-10-hotspot-stack-size.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/patches/openjdk-10-hotspot-stack-size.patch b/gnu/packages/patches/openjdk-10-hotspot-stack-size.patch
deleted file mode 100644
index 2c246dbdbc..0000000000
--- a/gnu/packages/patches/openjdk-10-hotspot-stack-size.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Dynamically allocate the stack since SIGSTKSZ is not constant since glibc 2.34.
-
-Backported from:
-
-  https://github.com/openjdk/jdk17u/commit/bb7c412e259893091210267252faf3c0a1be0969
-
-diff --git a/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c b/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
---- a/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
-+++ b/test/hotspot/jtreg/runtime/StackGuardPages/exeinvoke.c
-@@ -67,8 +67,17 @@ static void handler(int sig, siginfo_t *si, void *unused) {
-   longjmp(context, 1);
- }
- 
-+static char* altstack = NULL;
-+
- void set_signal_handler() {
--  static char altstack[SIGSTKSZ];
-+  if (altstack == NULL) {
-+    // Dynamically allocated in case SIGSTKSZ is not constant
-+    altstack = malloc(SIGSTKSZ);
-+    if (altstack == NULL) {
-+      fprintf(stderr, "Test ERROR. Unable to malloc altstack space\n");
-+      exit(7);
-+    }
-+  }
- 
-   stack_t ss = {
-     .ss_size = SIGSTKSZ,