summary refs log tree commit diff
path: root/gnu/packages/patches/pdfpc-build-with-vala-0.56.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/pdfpc-build-with-vala-0.56.patch')
-rw-r--r--gnu/packages/patches/pdfpc-build-with-vala-0.56.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/patches/pdfpc-build-with-vala-0.56.patch b/gnu/packages/patches/pdfpc-build-with-vala-0.56.patch
new file mode 100644
index 0000000000..e9a4060248
--- /dev/null
+++ b/gnu/packages/patches/pdfpc-build-with-vala-0.56.patch
@@ -0,0 +1,40 @@
+From 18beaecbbcc066e0d4c889b3aa3ecaa7351f7768 Mon Sep 17 00:00:00 2001
+Message-ID: <18beaecbbcc066e0d4c889b3aa3ecaa7351f7768.1711183363.git.vivien@planete-kraus.eu>
+From: Evgeny Stambulchik <fnevgeny@gmail.com>
+Date: Tue, 25 Apr 2023 16:11:25 +0300
+Subject: [PATCH] Create Lists of nullable types
+
+---
+This is the pull request for issue 686, merged in master, not released
+yet.
+
+ src/classes/drawings/drawing_commands.vala | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/classes/drawings/drawing_commands.vala b/src/classes/drawings/drawing_commands.vala
+index 77e56e6..c305a8c 100644
+--- a/src/classes/drawings/drawing_commands.vala
++++ b/src/classes/drawings/drawing_commands.vala
+@@ -54,8 +54,8 @@ namespace pdfpc {
+         }
+ 
+         public void clear() {
+-            this.drawing_commands = new List<DrawingCommand>();
+-            this.redo_commands = new List<DrawingCommand>();
++            this.drawing_commands = new List<DrawingCommand?>();
++            this.redo_commands = new List<DrawingCommand?>();
+         }
+ 
+         public void add_line(bool is_eraser,
+@@ -70,7 +70,7 @@ namespace pdfpc {
+ 
+             // After adding a new line you can no longer redo the old
+             // path.
+-            this.redo_commands = new List<DrawingCommand>(); // clear
++            this.redo_commands = new List<DrawingCommand?>(); // clear
+ 
+             bool new_path = true;
+             double epsilon = 1e-4; // Less than 0.1 pixel for a 1000x1000 img
+-- 
+2.41.0
+