summary refs log tree commit diff
path: root/gnu/packages/patches/python2-parameterized-docstring-test.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/python2-parameterized-docstring-test.patch')
-rw-r--r--gnu/packages/patches/python2-parameterized-docstring-test.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/python2-parameterized-docstring-test.patch b/gnu/packages/patches/python2-parameterized-docstring-test.patch
new file mode 100644
index 0000000000..14691e1904
--- /dev/null
+++ b/gnu/packages/patches/python2-parameterized-docstring-test.patch
@@ -0,0 +1,18 @@
+Skip unicode docstring test, required when running on Python 2.
+
+See <https://github.com/wolever/parameterized/issues/44>.
+
+--- a/parameterized/test.py
++++ b/parameterized/test.py
+@@ -284,11 +284,6 @@
+             "        More" %(foo, )
+         )
+ 
+-    @parameterized.expand([param("foo")])
+-    def test_unicode_docstring(self, foo):
+-        u"""Döcumentation."""
+-        self._assert_docstring(u"Döcumentation [with foo=%r]." %(foo, ))
+-
+     @parameterized.expand([param("foo", )])
+     def test_default_values_get_correct_value(self, foo, bar=12):
+         """Documentation"""