summary refs log tree commit diff
path: root/gnu/packages/patches/racket-rktboot-riscv64-support.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/racket-rktboot-riscv64-support.patch')
-rw-r--r--gnu/packages/patches/racket-rktboot-riscv64-support.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/racket-rktboot-riscv64-support.patch b/gnu/packages/patches/racket-rktboot-riscv64-support.patch
new file mode 100644
index 0000000000..f268b1e7f8
--- /dev/null
+++ b/gnu/packages/patches/racket-rktboot-riscv64-support.patch
@@ -0,0 +1,15 @@
+Submitted upstream:
+https://github.com/racket/racket/pull/4703
+
+diff --git a/racket/src/rktboot/machine-def.rkt b/racket/src/rktboot/machine-def.rkt
+index 8ff0688..59ebfc8 100644
+--- a/racket/src/rktboot/machine-def.rkt
++++ b/racket/src/rktboot/machine-def.rkt
+@@ -25,6 +25,7 @@
+                                      [(regexp-match? #rx"^t?arm32" target-machine) "arm32"]
+                                      [(regexp-match? #rx"^t?arm64" target-machine) "arm64"]
+                                      [(regexp-match? #rx"^t?ppc32" target-machine) "ppc32"]
++                                     [(regexp-match? #rx"^t?rv64" target-machine) "rv64"]
+                                      [(regexp-match? #rx"^t?pb" target-machine) "pb"]
+                                      [else (error "machine.def: cannot infer architecture")]))]
+                [s (regexp-replace* #rx"[$][(]Mend[)]" s