summary refs log tree commit diff
path: root/gnu/packages/patches/ungoogled-chromium-system-nspr.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/ungoogled-chromium-system-nspr.patch')
-rw-r--r--gnu/packages/patches/ungoogled-chromium-system-nspr.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/patches/ungoogled-chromium-system-nspr.patch b/gnu/packages/patches/ungoogled-chromium-system-nspr.patch
index 6fbc0a56a7..988296b143 100644
--- a/gnu/packages/patches/ungoogled-chromium-system-nspr.patch
+++ b/gnu/packages/patches/ungoogled-chromium-system-nspr.patch
@@ -17,8 +17,8 @@ https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/sys
 --- a/base/time/time.cc
 +++ b/base/time/time.cc
 @@ -14,7 +14,7 @@
- #include "base/macros.h"
- #include "base/no_destructor.h"
+ #include "base/optional.h"
+ #include "base/strings/string_util.h"
  #include "base/strings/stringprintf.h"
 -#include "base/third_party/nspr/prtime.h"
 +#include <nspr/prtime.h>
@@ -27,7 +27,7 @@ https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/sys
  
 --- a/base/BUILD.gn
 +++ b/base/BUILD.gn
-@@ -107,6 +107,9 @@ config("base_flags") {
+@@ -102,6 +102,9 @@
        "-Wglobal-constructors",
      ]
    }
@@ -37,7 +37,7 @@ https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/sys
  }
  
  config("base_implementation") {
-@@ -712,8 +715,6 @@ jumbo_component("base") {
+@@ -720,8 +723,6 @@
      "third_party/cityhash_v103/src/city_v103.h",
      "third_party/icu/icu_utf.cc",
      "third_party/icu/icu_utf.h",
@@ -48,19 +48,19 @@ https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/sys
      "threading/hang_watcher.cc",
 --- a/tools/gn/build/gen.py
 +++ b/tools/gn/build/gen.py
-@@ -339,6 +339,9 @@ def WriteGNNinja(path, platform, host, o
+@@ -380,6 +380,9 @@
        if not options.no_static_libstdcpp:
          ldflags.append('-static-libstdc++')
  
 +      # Additional system libraries that are used.
 +      libs.append('-lnspr4')
 +
-       # This is needed by libc++.
-       if not platform.is_mingw():
-         libs.append('-ldl')
+       if platform.is_mingw() or platform.is_msys():
+         cflags.remove('-std=c++17')
+         cflags.extend([
 --- a/third_party/blink/renderer/platform/BUILD.gn
 +++ b/third_party/blink/renderer/platform/BUILD.gn
-@@ -103,6 +103,9 @@
+@@ -110,6 +110,9 @@
      "//build/win:default_exe_manifest",
      "//third_party/icu",
    ]
@@ -72,7 +72,7 @@ https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/sys
  # This isn't strictly necessary since we can just add the deps to "platform",
 --- a/third_party/crashpad/crashpad/handler/BUILD.gn
 +++ b/third_party/crashpad/crashpad/handler/BUILD.gn
-@@ -140,6 +140,9 @@
+@@ -144,6 +144,9 @@
        "../third_party/mini_chromium:base",
        "../tools:tool_support",
      ]
@@ -104,7 +104,7 @@ https://salsa.debian.org/chromium-team/chromium/-/blob/master/debian/patches/sys
 +    "-lnspr4",
 +  ]
    if (is_ios) {
-     libs = [ "UIKit.framework" ]
+     frameworks = [ "UIKit.framework" ]
    }
 --- a/components/schema_org/BUILD.gn
 +++ b/components/schema_org/BUILD.gn