summary refs log tree commit diff
path: root/gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch')
-rw-r--r--gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch b/gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch
new file mode 100644
index 0000000000..97d18e0db7
--- /dev/null
+++ b/gnu/packages/patches/vorbis-tools-CVE-2014-9640.patch
@@ -0,0 +1,29 @@
+Index: vorbis-tools/oggenc/oggenc.c

+===================================================================

+--- vorbis-tools/oggenc/oggenc.c	(revision 19116)

++++ vorbis-tools/oggenc/oggenc.c	(revision 19117)

+@@ -98,4 +98,6 @@

+               0,0,0.f,

+               0, 0, 0, 0, 0};

++    input_format raw_format = {NULL, 0, raw_open, wav_close, "raw", 

++      N_("RAW file reader")};

+ 

+     int i;

+@@ -240,6 +242,4 @@

+         if(opt.rawmode)

+         {

+-            input_format raw_format = {NULL, 0, raw_open, wav_close, "raw", 

+-                N_("RAW file reader")};

+ 

+             enc_opts.rate=opt.raw_samplerate;

+Index: vorbis-tools/oggenc/skeleton.h

+===================================================================

+--- vorbis-tools/oggenc/skeleton.h	(revision 19116)

++++ vorbis-tools/oggenc/skeleton.h	(revision 19117)

+@@ -42,5 +42,5 @@

+     ogg_int64_t start_granule;                             /* start granule value */

+     ogg_uint32_t preroll;                                   /* preroll */

+-    unsigned char granule_shift; // a 8-bit field           /* 1 byte value holding the granule shift */

++    unsigned char granule_shift;                            /* 1 byte value holding the granule shift */

+     char *message_header_fields;                            /* holds all the message header fields */

+     /* current total size of the message header fields, for realloc purpose, initially zero */