summary refs log tree commit diff
path: root/gnu/packages/patches/zig-disable-libc-note-test.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/zig-disable-libc-note-test.patch')
-rw-r--r--gnu/packages/patches/zig-disable-libc-note-test.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/patches/zig-disable-libc-note-test.patch b/gnu/packages/patches/zig-disable-libc-note-test.patch
deleted file mode 100644
index 4508cee200..0000000000
--- a/gnu/packages/patches/zig-disable-libc-note-test.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-This test fails with "error.CompilationIncorrectlySucceeded".
-
-diff --git a/test/compile_errors.zig b/test/compile_errors.zig
-index b1eaa0302..621f9db0a 100644
---- a/test/compile_errors.zig
-+++ b/test/compile_errors.zig
-@@ -2943,15 +2943,15 @@ pub fn addCases(ctx: *TestContext) !void {
-             "tmp.zig:3:5: error: dependency on libc must be explicitly specified in the build command",
-         });
- 
--        ctx.testErrStage1("libc headers note",
--            \\const c = @cImport(@cInclude("stdio.h"));
--            \\export fn entry() void {
--            \\    _ = c.printf("hello, world!\n");
--            \\}
--        , &[_][]const u8{
--            "tmp.zig:1:11: error: C import failed",
--            "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
--        });
-+        // ctx.testErrStage1("libc headers note",
-+        //     \\const c = @cImport(@cInclude("stdio.h"));
-+        //     \\export fn entry() void {
-+        //     \\    _ = c.printf("hello, world!\n");
-+        //     \\}
-+        // , &[_][]const u8{
-+        //     "tmp.zig:1:11: error: C import failed",
-+        //     "tmp.zig:1:11: note: libc headers not available; compilation does not link against libc",
-+        // });
-     }
- 
-     ctx.testErrStage1("comptime vector overflow shows the index",