summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/freebayes-devendor-deps.patch152
-rw-r--r--gnu/packages/patches/guile-2.2-skip-so-test.patch23
-rw-r--r--gnu/packages/patches/idris-disable-test.patch19
-rw-r--r--gnu/packages/patches/ipxe-reproducible-geniso.patch77
-rw-r--r--gnu/packages/patches/mutt-CVE-2021-3181.patch45
-rw-r--r--gnu/packages/patches/podofo-cmake-3.12.patch19
-rw-r--r--gnu/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch (renamed from gnu/packages/patches/r-httpuv-1.5.4-unvendor-libuv.patch)0
-rw-r--r--gnu/packages/patches/tipp10-disable-downloader.patch165
-rw-r--r--gnu/packages/patches/tipp10-qt5.patch69
-rw-r--r--gnu/packages/patches/vcflib-use-shared-libraries.patch135
10 files changed, 550 insertions, 154 deletions
diff --git a/gnu/packages/patches/freebayes-devendor-deps.patch b/gnu/packages/patches/freebayes-devendor-deps.patch
new file mode 100644
index 0000000000..7e84666b85
--- /dev/null
+++ b/gnu/packages/patches/freebayes-devendor-deps.patch
@@ -0,0 +1,152 @@
+This patch is original to Guix, ongoing work to upstream bits as possible.
+
+From 9acc56db5e7469f5976be38b52ba4993de98ee38 Mon Sep 17 00:00:00 2001
+From: Efraim Flashner <efraim@flashner.co.il>
+Date: Sun, 17 Jan 2021 13:27:17 +0200
+Subject: [PATCH] devendor-dependants
+
+---
+ meson.build | 84 +++++++++++++++++++++++++++++++++++++++++------------
+ 1 file changed, 66 insertions(+), 18 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index f6bf242..bded4af 100644
+--- a/meson.build
++++ b/meson.build
+@@ -9,8 +9,13 @@ project('freebayes', ['cpp', 'c'],
+ 
+ zlib_dep = dependency('zlib')
+ lzma_dep = dependency('liblzma')
++simde_dep = dependency('simde')
+ bzip2_dep = dependency('bz2lib', required: false)
+ htslib_dep = dependency('htslib', required : false)
++tabixpp_dep = dependency('tabixpp', required : false)
++fastahack_dep = dependency('fastahack', required : false)
++smithwaterman_dep = dependency('smithwaterman', required : false)
++vcflib_dep = dependency('libvcflib', required: false)
+ thread_dep = dependency('threads')
+ 
+ if htslib_dep.found()
+@@ -59,6 +64,56 @@ else
+ ]
+ endif
+ 
++if tabixpp_dep.found()
++  tabixpp_includes = ''
++  tabixpp_src = []
++else
++  tabixpp_includes = [
++    'vcflib/tabixpp',
++    ]
++  tabixpp_src = [
++    'vcflib/tabixpp/tabix.cpp',
++    ]
++endif
++
++if vcflib_dep.found()
++  vcflib_includes = ''
++  vcflib_src = []
++else
++  vcflib_includes = [
++    'vcflib/src',
++    'vcflib/multichoose',
++    'vcflib/filevercmp',
++    ]
++  vcflib_src = [
++    'vcflib/src/Variant.cpp',
++    ]
++endif
++
++if fastahack_dep.found()
++  fastahack_src = []
++else
++  fastahack_src = [
++    'vcflib/fastahack/Fasta.cpp',
++    'vcflib/src/split.cpp',
++    ]
++endif
++
++if smithwaterman_dep.found()
++  smithwaterman_includes = ''
++  smithwaterman_src = []
++else
++  smithwaterman_includes = [
++    'vcflib/smithwaterman',
++    ]
++  smithwaterman_src = [
++    'vcflib/smithwaterman/SmithWatermanGotoh.cpp',
++    'vcflib/smithwaterman/disorder.cpp',
++    'vcflib/smithwaterman/Repeats.cpp',
++    'vcflib/smithwaterman/LeftAlign.cpp',
++    'vcflib/smithwaterman/IndelAllele.cpp',
++    ]
++endif
+ 
+ 
+ #
+@@ -105,23 +160,18 @@ seqlib_src = [
+ ]
+ 
+ vcflib_src = [
+-    'vcflib/tabixpp/tabix.cpp',
+-    'vcflib/src/Variant.cpp',
+-    'vcflib/smithwaterman/SmithWatermanGotoh.cpp',
+-    'vcflib/smithwaterman/disorder.cpp',
+-    'vcflib/smithwaterman/Repeats.cpp',
+-    'vcflib/smithwaterman/LeftAlign.cpp',
+-    'vcflib/smithwaterman/IndelAllele.cpp',
++    vcflib_src,
++    tabixpp_src,
++    smithwaterman_src,
+ ]
+ 
+ bamleftalign_src = [
+     'src/bamleftalign.cpp',
+     'src/IndelAllele.cpp',
+     'contrib/SeqLib/src/BamWriter.cpp',
+-    'vcflib/fastahack/Fasta.cpp',
+-    'vcflib/smithwaterman/LeftAlign.cpp',
+-    'vcflib/smithwaterman/IndelAllele.cpp',
+-    'vcflib/src/split.cpp',
++    fastahack_src,
++    smithwaterman_src,
++    vcflib_src,
+     'src/LeftAlign.cpp',
+ ]
+ 
+@@ -134,11 +184,9 @@ incdir = include_directories(
+     'ttmath',
+     'contrib',
+     'contrib/SeqLib',
+-    'vcflib/src',
+-    'vcflib/tabixpp',
+-    'vcflib/smithwaterman',
+-    'vcflib/multichoose',
+-    'vcflib/filevercmp')
++    tabixpp_includes,
++    smithwaterman_includes,
++    vcflib_includes)
+ 
+ c_args = ['-fpermissive','-w']
+ cpp_args = ['-fpermissive','-w','-Wc++14-compat']
+@@ -152,7 +200,7 @@ executable('freebayes',
+            include_directories : incdir,
+            cpp_args : cpp_args,
+            c_args :   c_args,
+-           dependencies: [zlib_dep, lzma_dep, htslib_dep, thread_dep],
++           dependencies: [zlib_dep, lzma_dep, simde_dep, htslib_dep, tabixpp_dep, smithwaterman_dep, vcflib_dep, thread_dep],
+            install: true
+           )
+ 
+@@ -165,7 +213,7 @@ executable('bamleftalign',
+            include_directories : incdir,
+            cpp_args : cpp_args,
+            c_args :   c_args,
+-           dependencies: [zlib_dep, lzma_dep, htslib_dep, thread_dep],
++           dependencies: [zlib_dep, lzma_dep, simde_dep, htslib_dep, tabixpp_dep, fastahack_dep, smithwaterman_dep, vcflib_dep, thread_dep],
+            install: true
+           )
+ 
+-- 
+2.30.0
+
diff --git a/gnu/packages/patches/guile-2.2-skip-so-test.patch b/gnu/packages/patches/guile-2.2-skip-so-test.patch
new file mode 100644
index 0000000000..e7c2594e91
--- /dev/null
+++ b/gnu/packages/patches/guile-2.2-skip-so-test.patch
@@ -0,0 +1,23 @@
+Skip 'test-stack-overflow' that crashes when using QEMU transparent emulation.
+
+--- a/test-suite/standalone/Makefile.in	1970-01-01 01:00:01.000000000 +0100
++++ b/test-suite/standalone/Makefile.in	2021-01-11 10:59:31.606269449 +0100
+@@ -102,8 +102,7 @@
+ 	test-scm-to-latin1-string$(EXEEXT) test-scm-values$(EXEEXT) \
+ 	test-scm-c-bind-keyword-arguments$(EXEEXT) \
+ 	test-srfi-4$(EXEEXT) $(am__append_6) $(am__EXEEXT_1) \
+-	test-smob-mark$(EXEEXT) test-smob-mark-race$(EXEEXT) \
+-	test-stack-overflow
++	test-smob-mark$(EXEEXT) test-smob-mark-race$(EXEEXT)
+ check_PROGRAMS = test-num2integral$(EXEEXT) test-round$(EXEEXT) \
+ 	test-foreign-object-c$(EXEEXT) test-list$(EXEEXT) \
+ 	test-unwind$(EXEEXT) test-conversion$(EXEEXT) \
+@@ -1938,7 +1937,7 @@
+ 	test-command-line-encoding test-command-line-encoding2 \
+ 	test-language test-guild-compile $(am__append_3) \
+ 	test-foreign-object-scm test-fast-slot-ref test-mb-regexp \
+-	test-use-srfi $(am__append_5) test-stack-overflow
++	test-use-srfi $(am__append_5)
+ BUILT_SOURCES = $(am__append_2)
+ EXTRA_DIST = test-import-order-a.scm test-import-order-b.scm \
+ 	test-import-order-c.scm test-import-order-d.scm \
diff --git a/gnu/packages/patches/idris-disable-test.patch b/gnu/packages/patches/idris-disable-test.patch
new file mode 100644
index 0000000000..ec8c7c8451
--- /dev/null
+++ b/gnu/packages/patches/idris-disable-test.patch
@@ -0,0 +1,19 @@
+The "pkg010" test output depends on the version of optparse-applicative being
+used.  The expected output requires optparse-applicative >= 0.15.1.0.  Skip
+the test for now.
+
+--- idris-1.3.3/test/TestData.hs	2021-01-19 23:05:24.238958262 -0600
++++ idris-1.3.3/test/TestData.hs	2021-01-19 23:10:33.314390997 -0600
+@@ -212,8 +212,10 @@
+       (  5, ANY  ),
+       (  6, ANY  ),
+       (  7, ANY  ),
+-      (  8, ANY  ),
+-      ( 10, ANY  )]),
++      (  8, ANY  )]),
++--      FIXME: Expected output depends on optparse-applicative version.
++--      See https://github.com/idris-lang/Idris-dev/issues/4896
++--      ( 10, ANY  )]),
+   ("prelude",         "Prelude",
+     [ (  1, ANY  )]),
+   ("primitives",      "Primitive types",
diff --git a/gnu/packages/patches/ipxe-reproducible-geniso.patch b/gnu/packages/patches/ipxe-reproducible-geniso.patch
new file mode 100644
index 0000000000..ff6aa1da94
--- /dev/null
+++ b/gnu/packages/patches/ipxe-reproducible-geniso.patch
@@ -0,0 +1,77 @@
+From 052d24d8217c51c572c2f6cbb4a687be2e8ba52d Mon Sep 17 00:00:00 2001
+From: Brice Waegeneire <brice@waegenei.re>
+Date: Fri, 5 Jun 2020 14:38:43 +0200
+Subject: [PATCH] [geniso] Make it reproducible
+
+Some timestamps get embedded in the generated ISO, making it
+unreproducible so we overwrite those timestamps to be at the UNIX epoch.
+---
+ src/util/geniso | 24 +++++++++++++++++++++---
+ 1 file changed, 21 insertions(+), 3 deletions(-)
+
+diff --git a/src/util/geniso b/src/util/geniso
+index ff090d4a..e032ffb0 100755
+--- a/src/util/geniso
++++ b/src/util/geniso
+@@ -11,6 +11,13 @@ function help() {
+ 	echo " -o FILE  save iso image to file"
+ }
+ 
++function reset_timestamp() {
++	for f in "$1"/*; do
++		touch -t 197001010100 "$f"
++	done
++	touch -t 197001010100 "$1"
++}
++
+ LEGACY=0
+ FIRST=""
+ 
+@@ -37,8 +44,9 @@ if [ -z "${OUT}" ]; then
+ 	exit 1
+ fi
+ 
+-# There should either be mkisofs or the compatible genisoimage program
+-for command in genisoimage mkisofs; do
++# There should either be mkisofs, xorriso or the compatible genisoimage
++# program
++for command in xorriso genisoimage mkisofs; do
+ 	if ${command} --version >/dev/null 2>/dev/null; then
+ 		mkisofs=(${command})
+ 		break
+@@ -46,8 +54,10 @@ for command in genisoimage mkisofs; do
+ done
+ 
+ if [ -z "${mkisofs}" ]; then
+-	echo "${0}: mkisofs or genisoimage not found, please install or set PATH" >&2
++	echo "${0}: mkisofs, xorriso or genisoimage not found, please install or set PATH" >&2
+ 	exit 1
++elif [ "$mkisofs" = "xorriso" ]; then
++	 mkisofs+=(-as mkisofs)
+ fi
+ 
+ dir=$(mktemp -d bin/iso.dir.XXXXXX)
+@@ -115,6 +125,8 @@ case "${LEGACY}" in
+ 			exit 1
+ 		fi
+ 
++		reset_timestamp "$dir"
++
+ 		# generate the iso image
+ 		"${mkisofs[@]}" -b boot.img -output ${OUT} ${dir}
+ 		;;
+@@ -127,6 +139,12 @@ case "${LEGACY}" in
+ 			cp ${LDLINUX_C32} ${dir}
+ 		fi
+ 
++		reset_timestamp "$dir"
++
++		if [ "${mkisofs[0]}" = "xorriso" ]; then
++			mkisofs+=(-isohybrid-mbr "$SYSLINUX_MBR_DISK_PATH")
++		fi
++
+ 		# generate the iso image
+ 		"${mkisofs[@]}" -b isolinux.bin -no-emul-boot -boot-load-size 4 -boot-info-table -output ${OUT} ${dir}
+ 
+-- 
+2.26.2
diff --git a/gnu/packages/patches/mutt-CVE-2021-3181.patch b/gnu/packages/patches/mutt-CVE-2021-3181.patch
new file mode 100644
index 0000000000..df5214b052
--- /dev/null
+++ b/gnu/packages/patches/mutt-CVE-2021-3181.patch
@@ -0,0 +1,45 @@
+Fix CVE-2021-3181:
+
+https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3181
+
+Patch copied from upstream source repository:
+
+https://gitlab.com/muttmua/mutt/-/commit/c059e20ea4c7cb3ee9ffd3500ffe313ae84b2545
+
+From c059e20ea4c7cb3ee9ffd3500ffe313ae84b2545 Mon Sep 17 00:00:00 2001
+From: Kevin McCarthy <kevin@8t8.us>
+Date: Sun, 17 Jan 2021 10:40:37 -0800
+Subject: [PATCH] Fix memory leak parsing group address.
+
+When there was a group address terminator with no previous addresses,
+an address would be allocated but not attached to the address list.
+
+Change this to only allocate when last exists.
+
+It would be more correct to not allocate at all unless we are inside a
+group list, but I will address that in a separate commit to master.
+---
+ rfc822.c | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/rfc822.c b/rfc822.c
+index 7ff4eaa3..ced619f2 100644
+--- a/rfc822.c
++++ b/rfc822.c
+@@ -587,11 +587,10 @@ ADDRESS *rfc822_parse_adrlist (ADDRESS *top, const char *s)
+ #endif
+ 
+       /* add group terminator */
+-      cur = rfc822_new_address ();
+       if (last)
+       {
+-	last->next = cur;
+-	last = cur;
++	last->next = rfc822_new_address ();
++	last = last->next;
+       }
+ 
+       phraselen = 0;
+-- 
+GitLab
+
diff --git a/gnu/packages/patches/podofo-cmake-3.12.patch b/gnu/packages/patches/podofo-cmake-3.12.patch
deleted file mode 100644
index 0a3c19b21a..0000000000
--- a/gnu/packages/patches/podofo-cmake-3.12.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-The build fails with cmake 3.12.0.  This patch will be obsolete with the next
-release.
-
-https://sourceforge.net/p/podofo/tickets/24/attachment/podofo-cmake-3.12.patch
-
-
---- a/test/TokenizerTest/CMakeLists.txt	2018-07-20 18:26:02.921494293 +0200
-+++ b/test/TokenizerTest/CMakeLists.txt	2018-07-20 18:34:53.727136443 +0200
-@@ -2,10 +2,3 @@
- TARGET_LINK_LIBRARIES(TokenizerTest ${PODOFO_LIB} ${PODOFO_LIB_DEPENDS})
- SET_TARGET_PROPERTIES(TokenizerTest PROPERTIES COMPILE_FLAGS "${PODOFO_CFLAGS}")
- ADD_DEPENDENCIES(TokenizerTest ${PODOFO_DEPEND_TARGET})
--
--# Copy the test samples over to the build tree
--ADD_CUSTOM_COMMAND(
--    TARGET TokenizerTest
--    POST_BUILD
--    COMMAND "${CMAKE_COMMAND}" -E copy_directory "${CMAKE_CURRENT_SOURCE_DIR}/objects" "${CMAKE_CURRENT_BINARY_DIR}/objects"
--    )
diff --git a/gnu/packages/patches/r-httpuv-1.5.4-unvendor-libuv.patch b/gnu/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch
index 0947718059..0947718059 100644
--- a/gnu/packages/patches/r-httpuv-1.5.4-unvendor-libuv.patch
+++ b/gnu/packages/patches/r-httpuv-1.5.5-unvendor-libuv.patch
diff --git a/gnu/packages/patches/tipp10-disable-downloader.patch b/gnu/packages/patches/tipp10-disable-downloader.patch
new file mode 100644
index 0000000000..4917a927f9
--- /dev/null
+++ b/gnu/packages/patches/tipp10-disable-downloader.patch
@@ -0,0 +1,165 @@
+https://salsa.debian.org/debian/tipp10/-/raw/debian/2.1.0-5/debian/patches/disable_downloaders.patch
+
+Author: Reiner Herrmann <reiner@reiner-h.de>
+Description: Disable downloaders
+ This makes porting to Qt5 much easier, as QHttp is no longer available.
+ But the functionality was not enabled anyway or is no longer useful.
+ .
+ - checkversion.h/.cpp:
+   At startup (while loading settings), Tipp10 "phones home" to do an
+   update check (www.tipp10.com/update/version.tipp10v210).
+   For a packaged software and one that is no longer being developed,
+   this does not make much sense.
+ - updatedialog.h/.cpp:
+   Can download newer sqlite database (www.tipp10.com/update/sql.tipp10v210.utf),
+   but this file is no longer available on the server (404).
+   The update action has also not been enabled in the menu, so the update
+   functionality was currently not active:
+     widget/mainwindow.cpp:143:  //fileMenu->addAction(updateAction);
+ - downloaddialog.h/.cpp:
+   Allows downloading lessons from user-specified location.
+   But the action (widget/startwidget.cpp -> lessonDownload) has not been part
+   of any menu, so it was also not in use.
+
+--- a/tipp10.pro
++++ b/tipp10.pro
+@@ -15,7 +15,6 @@
+ INCLUDEPATH     += 	.

+ CONFIG          += 	qt

+ QT              += 	sql

+-QT              += 	network

+ RC_FILE         += 	tipp10.rc

+ RESOURCES       += 	tipp10.qrc

+ HEADERS         += 	def/defines.h \

+@@ -36,15 +35,12 @@
+                     widget/settingspages.h \

+                     widget/lessondialog.h \

+                     widget/regexpdialog.h \

+-                    widget/downloaddialog.h \

+                     widget/lessonprintdialog.h \

+                     widget/lessonresult.h \

+-                    widget/updatedialog.h \

+                     widget/helpbrowser.h \

+                     widget/companylogo.h \

+                     widget/errormessage.h \

+                     widget/txtmessagedialog.h \

+-                    widget/checkversion.h \

+                     sql/connection.h \

+                     sql/lessontablesql.h \

+                     sql/chartablesql.h \

+@@ -70,15 +66,12 @@
+                     widget/settingspages.cpp \

+                     widget/lessondialog.cpp \

+                     widget/regexpdialog.cpp \

+-                    widget/downloaddialog.cpp \

+                     widget/lessonprintdialog.cpp \

+                     widget/lessonresult.cpp \

+-                    widget/updatedialog.cpp \

+                     widget/helpbrowser.cpp \

+                     widget/companylogo.cpp \

+                     widget/errormessage.cpp \

+                     widget/txtmessagedialog.cpp \

+-                    widget/checkversion.cpp \

+                     sql/lessontablesql.cpp \

+                     sql/chartablesql.cpp \

+                     sql/trainingsql.cpp \

+--- a/widget/mainwindow.cpp
++++ b/widget/mainwindow.cpp
+@@ -41,11 +41,9 @@
+ 

+ #include "mainwindow.h"

+ #include "settingsdialog.h"

+-#include "updatedialog.h"

+ #include "def/defines.h"

+ #include "def/errordefines.h"

+ #include "errormessage.h"

+-#include "checkversion.h"

+ 

+ MainWindow::MainWindow() {

+ 	trainingStarted = false;

+@@ -214,8 +212,8 @@
+ }

+ 

+ void MainWindow::showUpdate() {

+-	UpdateDialog updateDialog(this);

+-	updateDialog.exec();

++	//UpdateDialog updateDialog(this);

++	//updateDialog.exec();

+ 	// Fill lesson list after online update

+ 	startWidget->fillLessonList(false);

+ }

+@@ -486,6 +484,7 @@
+ 	settings.endGroup();

+ 

+     settings.beginGroup("general");

++#if 0

+     if (settings.value("check_new_version", true).toBool()) {

+ 

+         QDate lastVersionCheck = settings.value("last_version_check").toDate();

+@@ -499,6 +498,7 @@
+         }

+         settings.setValue("last_version_check", today);

+     }

++#endif

+     settings.endGroup();

+ }

+ 

+--- a/widget/settingspages.cpp
++++ b/widget/settingspages.cpp
+@@ -581,7 +581,7 @@
+ 

+ 	// Layout of group box vertical

+ 	QVBoxLayout *layout = new QVBoxLayout;

+-    layout->addWidget(checkNewVersion);

++    //layout->addWidget(checkNewVersion);

+     layout->addSpacing(1);

+     layout->addWidget(checkNativeStyle);

+     layout->setMargin(16);

+@@ -610,7 +610,6 @@
+     checkIntelligence->setChecked(settings.value("check_toggle_intelligence", true).toBool());

+ 	checkLimitLesson->setChecked(settings.value("check_limit_lesson", true).toBool());

+ 	checkLessonPublish->setChecked(settings.value("check_lesson_publish", true).toBool());

+-    checkNewVersion->setChecked(settings.value("check_new_version", true).toBool());

+     checkNativeStyle->setChecked(settings.value("check_native_style", false).toBool());

+ 	settings.endGroup();

+ }

+@@ -636,7 +635,6 @@
+ 	settings.setValue("check_limit_lesson", checkLimitLesson->isChecked());

+ 	settings.setValue("check_lesson_publish", checkLessonPublish->isChecked());

+ 	settings.setValue("check_native_style", checkNativeStyle->isChecked());

+-    settings.setValue("check_new_version", checkNewVersion->isChecked());

+     settings.endGroup();

+ 

+ 	return requireRestart;

+--- a/widget/startwidget.cpp
++++ b/widget/startwidget.cpp
+@@ -43,12 +43,10 @@
+ 

+ #include "startwidget.h"

+ #include "sql/startsql.h"

+-#include "updatedialog.h"

+ #include "def/defines.h"

+ #include "def/errordefines.h"

+ #include "errormessage.h"

+ #include "lessondialog.h"

+-#include "downloaddialog.h"

+ #include "illustrationdialog.h"

+ #include "txtmessagedialog.h"

+ 

+@@ -1048,7 +1046,7 @@
+ }

+ 

+ void StartWidget::clickDownloadLesson() {

+-

++#if 0

+ 	QStringList lessonData;

+ 

+ 	DownloadDialog downloadDialog(&lessonData, this);

+@@ -1083,6 +1081,7 @@
+ 			}

+ 		}

+ 	}

++#endif

+ }

+ 

+ void StartWidget::clickEditLesson() {

diff --git a/gnu/packages/patches/tipp10-qt5.patch b/gnu/packages/patches/tipp10-qt5.patch
new file mode 100644
index 0000000000..34ad5cd708
--- /dev/null
+++ b/gnu/packages/patches/tipp10-qt5.patch
@@ -0,0 +1,69 @@
+https://salsa.debian.org/debian/tipp10/-/raw/debian/2.1.0-5/debian/patches/qt5.patch
+
+Author: Reiner Herrmann <reiner@reiner-h.de>
+Description: Port to Qt5
+Bug-Debian: https://bugs.debian.org/875207
+
+--- a/tipp10.pro
++++ b/tipp10.pro
+@@ -14,6 +14,7 @@
+ DEPENDPATH      += 	.

+ INCLUDEPATH     += 	.

+ CONFIG          += 	qt

++QT              += 	widgets multimedia printsupport

+ QT              += 	sql

+ RC_FILE         += 	tipp10.rc

+ RESOURCES       += 	tipp10.qrc

+--- a/main.cpp
++++ b/main.cpp
+@@ -24,7 +24,6 @@
+ ****************************************************************/

+ 

+ #include <QApplication>

+-#include <QPlastiqueStyle>

+ #include <QString>

+ #include <QSettings>

+ #include <QCoreApplication>

+@@ -212,7 +211,7 @@
+ 

+     // Set windows style

+ 	if (!useNativeStyle) {

+-	    app.setStyle("plastique");

++	    app.setStyle("fusion");

+     }

+ 

+ 	// Translation

+--- a/games/abcrainwidget.cpp
++++ b/games/abcrainwidget.cpp
+@@ -235,8 +235,7 @@
+ 		charballs.last()->wind = (qrand() % 8) + 2;

+ 		charballs.last()->rad = 0;

+ 

+-		chartext.append(new QGraphicsTextItem(QString(characterTemp),

+-			charballs.last(), scene));

++		chartext.append(new QGraphicsTextItem(QString(characterTemp), charballs.last()));

+ 		chartext.last()->setFont(QFont("Courier", 16, 100));

+ 		chartext.last()->setPos(-(chartext.last()->boundingRect().width() / 2), -(chartext.last()->boundingRect().height() / 2));

+ 

+--- a/sql/chartablesql.cpp
++++ b/sql/chartablesql.cpp
+@@ -137,7 +137,7 @@
+ 	sortColumn(4);

+ 

+ 	headerview->setStretchLastSection(true);

+-	headerview->setResizeMode(QHeaderView::Interactive);

++	headerview->setSectionResizeMode(QHeaderView::Interactive);

+ 	headerview->setSortIndicatorShown(true);

+ 

+ 	// Resize the columns

+--- a/sql/lessontablesql.cpp
++++ b/sql/lessontablesql.cpp
+@@ -202,7 +202,7 @@
+ 	sortColumn(-1);

+ 

+ 	headerview->setStretchLastSection(true);

+-	headerview->setResizeMode(QHeaderView::Interactive);

++	headerview->setSectionResizeMode(QHeaderView::Interactive);

+ 	headerview->setSortIndicatorShown(true);

+ 

+ 	// Resize the columns

diff --git a/gnu/packages/patches/vcflib-use-shared-libraries.patch b/gnu/packages/patches/vcflib-use-shared-libraries.patch
deleted file mode 100644
index e198ec663c..0000000000
--- a/gnu/packages/patches/vcflib-use-shared-libraries.patch
+++ /dev/null
@@ -1,135 +0,0 @@
-This patch is a combination of many of the patches from Debian:
-https://sources.debian.org/src/libvcflib/1.0.1+dfsg-3/debian/patches/
-
----
- Makefile | 63 +++++++++++---------------------------------------------
- 1 file changed, 12 insertions(+), 51 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 6b13350..be85f22 100644
---- a/Makefile
-+++ b/Makefile
-@@ -114,43 +114,25 @@ BIN_SOURCES = src/vcfecho.cpp \
- 			  src/vcfnull2ref.cpp \
- 			  src/vcfinfosummarize.cpp
- 
--# when we can figure out how to build on mac
--# src/vcfsom.cpp
--
- #BINS = $(BIN_SOURCES:.cpp=)
- BINS = $(addprefix $(BIN_DIR)/,$(notdir $(BIN_SOURCES:.cpp=)))
- SHORTBINS = $(notdir $(BIN_SOURCES:.cpp=))
- 
--TABIX = tabixpp/tabix.o
--FASTAHACK = fastahack/Fasta.o
--SMITHWATERMAN = smithwaterman/SmithWatermanGotoh.o
--REPEATS = smithwaterman/Repeats.o
--INDELALLELE = smithwaterman/IndelAllele.o
--DISORDER = smithwaterman/disorder.o
--LEFTALIGN = smithwaterman/LeftAlign.o
--FSOM = fsom/fsom.o
- FILEVERCMP = filevercmp/filevercmp.o
- 
--# Work out how to find htslib
--# Use the one we ship in tabixpp unless told otherwise by the environment
--HTS_LIB ?= $(VCF_LIB_LOCAL)/tabixpp/htslib/libhts.a
--HTS_INCLUDES ?= -I$(VCF_LIB_LOCAL)/tabixpp/htslib
--HTS_LDFLAGS ?= -L$(VCF_LIB_LOCAL)/tabixpp/htslib -lhts -lbz2 -lm -lz -llzma -pthread
--
--
--INCLUDES = $(HTS_INCLUDES) -I$(INC_DIR) 
--LDFLAGS = -L$(LIB_DIR) -lvcflib $(HTS_LDFLAGS) -lpthread -lz -lm -llzma -lbz2
-+INCLUDES = -I$(INC_DIR) $(shell pkg-config --cflags htslib fastahack smithwaterman tabixpp)
-+LDFLAGS = -L$(LIB_DIR) -lvcflib -lpthread -lz -lstdc++ -lm -llzma -lbz2 $(shell pkg-config --libs htslib fastahack smithwaterman tabixpp)
- 
- 
- 
--all: $(OBJECTS) $(BINS) scriptToBin
-+all: $(OBJECTS) $(BINS) scriptToBin libvcflib.a
- 
- scriptToBin: $(BINS)
- 	$(CP) scripts/* $(BIN_DIR)
- 
- GIT_VERSION += $(shell git describe --abbrev=4 --dirty --always)
- 
--CXXFLAGS = -Ofast -D_FILE_OFFSET_BITS=64 -std=c++0x
-+CXXFLAGS = -Ofast -D_FILE_OFFSET_BITS=64 -std=c++0x -fPIC
- #CXXFLAGS = -O2
- #CXXFLAGS = -pedantic -Wall -Wshadow -Wpointer-arith -Wcast-qual
- 
-@@ -168,7 +150,7 @@ profiling:
- gprof:
- 	$(MAKE) CXXFLAGS="$(CXXFLAGS) -pg" all
- 
--$(OBJECTS): $(SOURCES) $(HEADERS) $(TABIX) multichoose pre $(SMITHWATERMAN) $(FILEVERCMP) $(FASTAHACK)
-+$(OBJECTS): $(SOURCES) $(HEADERS) multichoose pre $(FILEVERCMP)
- 	$(CXX) -c -o $@ src/$(*F).cpp $(INCLUDES) $(LDFLAGS) $(CXXFLAGS) && $(CP) src/*.h* $(VCF_LIB_LOCAL)/$(INC_DIR)/
- 
- multichoose: pre
-@@ -177,39 +159,22 @@ multichoose: pre
- intervaltree: pre
- 	cd intervaltree && $(MAKE) && $(CP) *.h* $(VCF_LIB_LOCAL)/$(INC_DIR)/
- 
--$(TABIX): pre
--	cd tabixpp && INCLUDES="$(HTS_INCLUDES)" LIBPATH="-L. $(HTS_LDFLAGS)" HTSLIB="$(HTS_LIB)" $(MAKE) && $(CP) *.h* $(VCF_LIB_LOCAL)/$(INC_DIR)/
--
--$(SMITHWATERMAN): pre
--	cd smithwaterman && $(MAKE) && $(CP) *.h* $(VCF_LIB_LOCAL)/$(INC_DIR)/ && $(CP) *.o $(VCF_LIB_LOCAL)/$(OBJ_DIR)/
--
--$(DISORDER): $(SMITHWATERMAN)
--
--$(REPEATS): $(SMITHWATERMAN)
--
--$(LEFTALIGN): $(SMITHWATERMAN)
--
--$(INDELALLELE): $(SMITHWATERMAN)
--
--$(FASTAHACK): pre
--	cd fastahack && $(MAKE) && $(CP) *.h* $(VCF_LIB_LOCAL)/$(INC_DIR)/ && $(CP) Fasta.o $(VCF_LIB_LOCAL)/$(OBJ_DIR)/
--
--#$(FSOM):
--#	cd fsom && $(CXX) $(CXXFLAGS) -c fsom.c -lm
--
- $(FILEVERCMP): pre
- 	cd filevercmp && make && $(CP) *.h* $(VCF_LIB_LOCAL)/$(INC_DIR)/ && $(CP) *.o $(VCF_LIB_LOCAL)/$(INC_DIR)/
- 
- $(SHORTBINS): pre
- 	$(MAKE) $(BIN_DIR)/$@
- 
--$(BINS): $(BIN_SOURCES) libvcflib.a $(OBJECTS) $(SMITHWATERMAN) $(FASTAHACK) $(DISORDER) $(LEFTALIGN) $(INDELALLELE) $(SSW) $(FILEVERCMP) pre intervaltree
-+$(BINS): $(BIN_SOURCES) libvcflib.so $(OBJECTS) $(SSW) $(FILEVERCMP) pre intervaltree
- 	$(CXX) src/$(notdir $@).cpp -o $@ $(INCLUDES) $(LDFLAGS) $(CXXFLAGS) -DVERSION=\"$(GIT_VERSION)\"
- 
--libvcflib.a: $(OBJECTS) $(SMITHWATERMAN) $(REPEATS) $(FASTAHACK) $(DISORDER) $(LEFTALIGN) $(INDELALLELE) $(SSW) $(FILEVERCMP) $(TABIX) pre
--	ar rs libvcflib.a $(OBJECTS) smithwaterman/sw.o $(FASTAHACK) $(SSW) $(FILEVERCMP) $(TABIX)
-+libvcflib.a: $(OBJECTS) $(SSW) $(FILEVERCMP) pre
-+	ar rs libvcflib.a $(OBJECTS) $(SSW) $(FILEVERCMP)
- 	$(CP) libvcflib.a $(LIB_DIR)
- 
-+libvcflib.so: $(OBJECTS) $(SSW) $(FILEVERCMP) pre
-+	$(CXX) -shared -o libvcflib.so $(OBJECTS) $(SSW) $(FILEVERCMP)
-+	$(CP) libvcflib.so $(LIB_DIR)
- 
- test: $(BINS)
- 	@prove -Itests/lib -w tests/*.t
-@@ -230,16 +195,12 @@ clean:
- 	$(RM) $(BINS) $(OBJECTS)
- 	$(RM) ssw_cpp.o ssw.o
- 	$(RM) libvcflib.a
-+	$(RM) libvcflib.so
- 	$(RM) -r $(BIN_DIR)
- 	$(RM) -r $(LIB_DIR)
- 	$(RM) -r $(INC_DIR)
- 	$(RM) -r $(OBJ_DIR)
--	$(MAKE) clean -C tabixpp
--	$(MAKE) clean -C smithwaterman
--	$(MAKE) clean -C fastahack
- 	$(MAKE) clean -C multichoose
--	$(MAKE) clean -C fsom
--	$(MAKE) clean -C libVCFH
- 	$(MAKE) clean -C test
- 	$(MAKE) clean -C filevercmp
- 	$(MAKE) clean -C intervaltree
--- 
-2.28.0
-