summary refs log tree commit diff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gcc-4.9-inline.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/gcc-4.9-inline.patch b/gnu/packages/patches/gcc-4.9-inline.patch
new file mode 100644
index 0000000000..f2762c903a
--- /dev/null
+++ b/gnu/packages/patches/gcc-4.9-inline.patch
@@ -0,0 +1,13 @@
+diff -ru a/gcc/cp/cfns.h b/gcc/cp/cfns.h
+--- a/gcc/cp/cfns.h	1970-01-01 01:00:01.000000000 +0100
++++ b/gcc/cp/cfns.h	2023-04-23 09:23:28.883815598 +0200
+@@ -53,6 +53,9 @@
+ static unsigned int hash (const char *, unsigned int);
+ #ifdef __GNUC__
+ __inline
++#ifdef __GNUC_STDC_INLINE__
++__attribute__ ((__gnu_inline__))
++#endif
+ #endif
+ const char * libc_name_p (const char *, unsigned int);
+ /* maximum key range = 391, duplicates = 0 */