summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index ef81900069..25f5fbc77f 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -117,7 +117,7 @@
 (define-public capypdf
   (package
     (name "capypdf")
-    (version "0.3.0")
+    (version "0.4.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -125,7 +125,7 @@
                     (commit version)))
               (file-name (git-file-name name version))
               (sha256
-               (base32 "193izn2jw55w2dxy6l0vz5zrlar9lm7a6z443nw0vs4mlj4jnasi"))))
+               (base32 "1kn46n3j5fygivmd6ldnv8vdwfv48ffaizq61yy4z9w2jm6fgxim"))))
     (build-system meson-build-system)
     (arguments
      (list #:meson meson/newer
@@ -220,7 +220,7 @@ comparison modes: words, characters, and appearance.")
            gettext-minimal
            ghostscript
            pkg-config
-           texlive-tiny))
+           (texlive-updmap.cfg)))
     (inputs
      (list poppler))
     (home-page "https://github.com/trueroad/extractpdfmark")
@@ -489,13 +489,13 @@ reading and editing of existing PDF files.")
 (define-public xpdf
   (package
    (name "xpdf")
-   (version "4.03")
+   (version "4.04")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://dl.xpdfreader.com/xpdf-" version ".tar.gz"))
       (sha256
-       (base32 "0ip81c9vy0igjnasl9iv2lz214fb01vvvdzbvjmgwc63fi1jgr0g"))))
+       (base32 "1pmsark94xza8q31wvfvp8n7l3c4qfd4ggj09i98y13npzy27kk3"))))
    (build-system cmake-build-system)
    (inputs (list cups freetype libpng qtbase-5 zlib))
    (arguments
@@ -1046,8 +1046,7 @@ using a stylus.")
            libzip
            lua
            poppler
-           portaudio
-           texlive-bin))
+           portaudio))
     (home-page "https://github.com/xournalpp/xournalpp")
     (synopsis "Handwriting notetaking software with PDF annotation support")
     (description "Xournal++ is a hand note taking software written in