summary refs log tree commit diff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index d561f73dbd..378655a70f 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -341,10 +341,14 @@ please install the @code{flyer-composer-gui} package.")))
     ;; different solution to the circular dependency mentioned above.
     (list glib))
    (native-inputs
+    (append
       (list pkg-config
             `(,glib "bin") ; glib-mkenums, etc.
             gobject-introspection
-            python))
+            python)
+      (if (%current-target-system)
+        (list pkg-config-for-build)
+        '())))
    (arguments
     (list
      ;; The Poppler test suite needs to be downloaded separately and contains