summary refs log tree commit diff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 7bf58832bc..5ef56227ce 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -39,6 +39,7 @@
   #:use-module (gnu packages web)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system perl)
   #:use-module (gnu packages perl))
 
@@ -715,6 +716,29 @@ contents of a file is equal to a particular string.")
 automatically aggregated and output to STDOUT.")
     (license perl-license)))
 
+(define-public perl-test-inter
+  (package
+    (name "perl-test-inter")
+    (version "1.10")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/SBECK-github/Test-Inter")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0ii3avmd31j3kxg456jqvlj5w0hpywpj51mqm4ccnjm820yv8irb"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/pod/Test::Inter")
+    (synopsis "Framework for more readable interactive test scripts")
+    (description
+     "@code{Test::Inter} is another framework for writing test scripts, which
+offer the ability to access specific tests in a reasonably interactive
+fashion, primarily for debugging purposes.  Much of the syntax is loosely
+inspired by @code{Test::More}.")
+    (license perl-license)))
+
 (define-public perl-test-leaktrace
   (package
     (name "perl-test-leaktrace")