summary refs log tree commit diff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm242
1 files changed, 97 insertions, 145 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 87f233a3aa..bde3079bef 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -87,9 +87,7 @@ lexically, just dynamically.")
          (add-after 'unpack 'set-env
            (lambda _ (setenv "PERL_USE_UNSAFE_INC" "1") #t)))))
     (propagated-inputs
-     `(("perl-importer" ,perl-importer)
-       ("perl-term-table" ,perl-term-table)
-       ("perl-sub-info" ,perl-sub-info)))
+     (list perl-importer perl-term-table perl-sub-info))
     (home-page "https://metacpan.org/pod/Test2-Suite")
     (synopsis "Full set of tools for Test2::Suite")
     (description "This package provides a rich set of tools, plugins, bundles,
@@ -110,9 +108,9 @@ etc built upon the Test2 testing library.")
           "002qk6qsm0l6r2kaxywvc38w0yf0mlavgywq8li076pn6kcw3242"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-ipc-run3" ,perl-ipc-run3)))
+     (list perl-ipc-run3))
     (propagated-inputs
-     `(("perl-test2-suite" ,perl-test2-suite)))
+     (list perl-test2-suite))
     (home-page "https://metacpan.org/release/Test2-Plugin-NoWarnings")
     (synopsis "Fail if tests warn")
     (description "Loading this plugin causes your tests to fail if there any
@@ -134,11 +132,9 @@ warning content is outputted via diag.")
          "056hibgg3i2b89mwr76vyxi6ayb3hqjqcwicvn3s5lximsma3517"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-algorithm-diff" ,perl-algorithm-diff)
-       ("perl-text-diff" ,perl-text-diff)))
+     (list perl-algorithm-diff perl-text-diff))
     (propagated-inputs
-     `(("perl-spiffy" ,perl-spiffy)
-       ("perl-test-deep" ,perl-test-deep)))
+     (list perl-spiffy perl-test-deep))
     (home-page "https://metacpan.org/release/Test-Base")
     (synopsis "Data-driven testing framework for Perl")
     (description "Test::Base gives a way to trivially write your own test
@@ -162,7 +158,7 @@ patterns, so that you can write tests with a minimum of code.")
          "1vjinlixxdx6gfcw8y1dw2rla8bfhi8nmgcqr3nffc7kqskcrz36"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-cpan-meta-check" ,perl-cpan-meta-check)))
+     (list perl-cpan-meta-check))
     (home-page "https://metacpan.org/release/Test-CheckDeps")
     (synopsis "Check for presence of dependencies")
     (description
@@ -186,11 +182,9 @@ installed properly.")
          "0l0kk5jvxjkic2jkf1r7v41irb344aasnzr3f5ygjgxgiknm9489"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-test-exception" ,perl-test-exception)))
+     (list perl-test-exception))
     (inputs
-     `(("perl-module-runtime" ,perl-module-runtime)
-       ("perl-mro-compat" ,perl-mro-compat)
-       ("perl-try-tiny" ,perl-try-tiny)))
+     (list perl-module-runtime perl-mro-compat perl-try-tiny))
     (home-page "https://metacpan.org/release/Test-Class")
     (synopsis "Easily create test classes in an xUnit/JUnit style")
     (description "@code{Test::Class} provides a simple way of creating classes
@@ -217,13 +211,10 @@ Built using @code{Test::Builder}, it was designed to work with other
          "1zvx9hil0mg0pnb8xfa4m0xgjpvh8s5gnbyprq3xwpdsdgcdwk33"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-module-build" ,perl-module-build)))
+     (list perl-module-build))
     (inputs
-     `(("perl-test-class" ,perl-test-class)
-       ("perl-test-most" ,perl-test-most)
-       ("perl-module-runtime" ,perl-module-runtime)
-       ("perl-try-tiny" ,perl-try-tiny)
-       ("perl-mro-compat" ,perl-mro-compat)))
+     (list perl-test-class perl-test-most perl-module-runtime
+           perl-try-tiny perl-mro-compat))
     (home-page "https://metacpan.org/release/Test-Class-Most")
     (synopsis "Test classes the easy way")
     (description "@code{Test::Class::Most} provides some more convenience when
@@ -243,18 +234,15 @@ using @code{Test::Class}.")
         (base32 "0yijspncqgmbkkxrh66xx1pliajar05yqhzq6m4nb6p8x1lmb39k"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-file-pushd" ,perl-file-pushd)
-       ("perl-test-requires" ,perl-test-requires)
-       ("perl-test-deep" ,perl-test-deep)
-       ("perl-test-warnings" ,perl-test-warnings)
-       ("perl-test-needs" ,perl-test-needs)))
+     (list perl-file-pushd perl-test-requires perl-test-deep
+           perl-test-warnings perl-test-needs))
     (propagated-inputs
-     `(("perl-namespace-clean" ,perl-namespace-clean)
-       ("perl-package-stash" ,perl-package-stash)
-       ("perl-sub-identify" ,perl-sub-identify)
-       ("perl-sub-exporter" ,perl-sub-exporter)
-       ("perl-file-find-rule" ,perl-file-find-rule)
-       ("perl-file-find-rule-perl" ,perl-file-find-rule-perl)))
+     (list perl-namespace-clean
+           perl-package-stash
+           perl-sub-identify
+           perl-sub-exporter
+           perl-file-find-rule
+           perl-file-find-rule-perl))
     (home-page "https://metacpan.org/release/Test-CleanNamespaces")
     (synopsis "Check for uncleaned imports")
     (description "This module lets you check your module's namespaces for
@@ -277,7 +265,7 @@ called as methods, which usually isn't want you want.")
                 "0cwm3c4d49mdrbm6vgh78b3x8mk730l0zg8i7xb9z8bkx9pzr8r8"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-module-build" ,perl-module-build)))
+     (list perl-module-build))
     (home-page "https://github.com/danboo/perl-test-command")
     (synopsis "Test routines for external commands")
     (description
@@ -301,9 +289,7 @@ output and standard error of external commands.")
          "1dcdbbdwdyhpldkhjzc9rvzlmb5jbil6fwh2x07nsfdwysf4ynzm"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-test-cpan-meta-json" ,perl-test-cpan-meta-json)
-       ("perl-test-pod" ,perl-test-pod)
-       ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+     (list perl-test-cpan-meta-json perl-test-pod perl-test-pod-coverage))
     (home-page
      "https://metacpan.org/release/Test-CPAN-Meta")
     (synopsis "Validate your CPAN META.yml files")
@@ -328,10 +314,9 @@ specification.")
          "1jg9ka50ixwq083wd4k12rhdjq87w0ihb34gd8jjn7gvvyd51b37"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-test-pod" ,perl-test-pod)
-       ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+     (list perl-test-pod perl-test-pod-coverage))
     (inputs
-     `(("perl-json" ,perl-json)))
+     (list perl-json))
     (home-page
      "https://metacpan.org/release/Test-CPAN-Meta-JSON")
     (synopsis "Validate your CPAN META.json files")
@@ -352,7 +337,7 @@ specification.")
                (base32
                 "1kdy06r0yg7zwarqglc9163vbfb0sfc4s6ld4pw5q7i9f7mghzi0"))))
     (build-system perl-build-system)
-    (inputs `(("perl-test-nowarnings" ,perl-test-nowarnings)))
+    (inputs (list perl-test-nowarnings))
     (synopsis "Flexible deep comparison for the Test::Builder framework")
     (description
      "Test::Deep compares two structures by going through each level, ensuring
@@ -375,10 +360,9 @@ structures without getting caught in an infinite loop.")
         (base32 "1nkqr3m4lbzw7fkkzah42aiqlhxapamk6kw7hj90cjwkifsbp3f8"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-module-build" ,perl-module-build)))
+     (list perl-module-build))
     (propagated-inputs
-     `(("perl-text-diff" ,perl-text-diff)
-       ("perl-capture-tiny" ,perl-capture-tiny)))
+     (list perl-text-diff perl-capture-tiny))
     (home-page "https://metacpan.org/release/Test-Differences")
     (synopsis "Test strings and data structures and show differences")
     (description "This module exports three test functions and four diff-style
@@ -401,13 +385,11 @@ functions.")
          "1hpafgr93jjl6s8spskhdxhgich4cccmaiq99mla5diyj4iv6ckk"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-pod-coverage" ,perl-pod-coverage)
-       ("perl-test-pod" ,perl-test-pod)
-       ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+     (list perl-pod-coverage perl-test-pod perl-test-pod-coverage))
     (home-page "https://metacpan.org/release/Test-Dir")
     (synopsis "Utilities for testing directory attributes")
     (description
-     "This modules provides a collection of test utilities for directory
+     "This module provides a collection of test utilities for directory
 attributes.")
     (license perl-license)))
 
@@ -424,7 +406,7 @@ attributes.")
         (base32
          "1ncql08cizhicbxwd753b4czns8nlcnlw0zfjcfrbdd41x4j6hqr"))))
     (build-system perl-build-system)
-    (native-inputs `(("perl-test-exception" ,perl-test-exception)))
+    (native-inputs (list perl-test-exception))
     (home-page "https://metacpan.org/release/Test-Directory")
     (synopsis "Perl extension for maintaining test directories")
     (description "Testing code can involve making sure that files are created
@@ -449,9 +431,9 @@ files, as well as to verify that there are no missing or unknown files.")
         (base32 "1ifpff5simjslabwy7ac6kdylv4c0b5b39fgpwf9ha16yh6w49ix"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-module-build" ,perl-module-build)))
+     (list perl-module-build))
     (propagated-inputs
-     `(("perl-module-manifest" ,perl-module-manifest)))
+     (list perl-module-manifest))
     (home-page "https://github.com/jawnsy/Test-DistManifest")
     (synopsis "Author test that validates a package @file{MANIFEST}")
     (description
@@ -474,12 +456,10 @@ files, as well as to verify that there are no missing or unknown files.")
         "0s1bj459qaw2x1fckklv9irpf3mr8gp2cm9vlyrb5dyanrzx1v2h"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-module-build" ,perl-module-build)))
+     (list perl-module-build))
     (propagated-inputs
-     `(("perl-file-find-rule" ,perl-file-find-rule)
-       ("perl-pod-coverage" ,perl-pod-coverage)
-       ("perl-test-pod" ,perl-test-pod)
-       ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+     (list perl-file-find-rule perl-pod-coverage perl-test-pod
+           perl-test-pod-coverage))
     (home-page "https://metacpan.org/release/Test-Distribution")
     (synopsis "Perform tests on all modules of a distribution")
     (description "When used in a test script @code{Test::Distribution}
@@ -531,9 +511,9 @@ and/or windows line endings in your perl code.")
          "0cxm7s4bg0xpxa6l6996a6iq3brr4j7p4hssnkc6dxv4fzq16sqm"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-module-build" ,perl-module-build)))
+     (list perl-module-build))
     (propagated-inputs
-     `(("perl-sub-uplevel" ,perl-sub-uplevel)))
+     (list perl-sub-uplevel))
     (home-page "https://metacpan.org/release/Test-Exception")
     (synopsis "Test exception based code")
     (description "This module provides a few convenience methods for testing
@@ -556,7 +536,7 @@ Test::More and friends.")
          "0vx9chcp5x8m0chq574p9fnfckh5gl94j7904rh9v17n568fyd6s"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-capture-tiny" ,perl-capture-tiny)))
+     (list perl-capture-tiny))
     (home-page "https://metacpan.org/release/Test-FailWarnings")
     (synopsis "Add test failures if warnings are caught")
     (description
@@ -576,7 +556,7 @@ Test::More and friends.")
         (base32
          "1c6bs68mss4q7cyapkv2c0jn66i21050p0faxf3s3417gdffzp5w"))))
     (build-system perl-build-system)
-    (propagated-inputs `(("perl-try-tiny" ,perl-try-tiny)))
+    (propagated-inputs (list perl-try-tiny))
     (home-page "https://metacpan.org/release/Test-Fatal")
     (synopsis "Simple helpers for testing code with exceptions")
     (description "Test::Fatal is an alternative to the popular
@@ -599,7 +579,7 @@ testing exception-throwing code with about the same amount of typing.")
         (base32 "0195dnvwxxphwbglw6cjid3j7kq15xg46lr7r4468idvadyal6c7"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-test-utf8" ,perl-test-utf8)))
+     (list perl-test-utf8))
     (home-page "https://metacpan.org/release/Test-File")
     (synopsis "Utilities for testing file attributes")
     (description
@@ -623,11 +603,9 @@ attributes.")
          "0g8zgfyw84181snw7ghahnl9r4lrmlfj7zwi76sv8d0bj7xssvyd"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-module-build" ,perl-module-build)))
+     (list perl-module-build))
     (propagated-inputs
-     `(("perl-test-pod" ,perl-test-pod)
-       ("perl-test-pod-coverage" ,perl-test-pod-coverage)
-       ("perl-text-diff" ,perl-text-diff)))
+     (list perl-test-pod perl-test-pod-coverage perl-text-diff))
     (home-page "https://metacpan.org/release/Test-File-Contents")
     (synopsis "Test routines for examining the contents of files")
     (description
@@ -649,12 +627,12 @@ files.")
           "1bbs6cx69wcinq77gif4i4pmrj8a7lwb92sgvvxzrwmjnk5lfdmk"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-class-tiny" ,perl-class-tiny)
-       ("perl-file-copy-recursive" ,perl-file-copy-recursive)
-       ("perl-file-sharedir" ,perl-file-sharedir)
-       ("perl-path-tiny" ,perl-path-tiny)
-       ("perl-scope-guard" ,perl-scope-guard)
-       ("perl-test-fatal" ,perl-test-fatal)))
+     (list perl-class-tiny
+           perl-file-copy-recursive
+           perl-file-sharedir
+           perl-path-tiny
+           perl-scope-guard
+           perl-test-fatal))
     (home-page "https://github.com/kentnl/Test-File-ShareDir")
     (synopsis "Dist oriented ShareDir tester")
     (description "This module creates a Fake ShareDir for your modules
@@ -676,7 +654,7 @@ for testing.")
          "1gpw4mjw68gnby8s4cifvbz6g2923xsc189jkw9d27i8qv20qiba"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-path-tiny" ,perl-path-tiny)))
+     (list perl-path-tiny))
     (home-page "https://metacpan.org/release/Test-Filename")
     (synopsis "Portable filename comparison")
     (description "Test::Filename provides functions to convert all path
@@ -699,8 +677,7 @@ separators automatically.")
          "1zn33yigznq7i1jr4yjr4lxvc6bn7znkbqdzj7slhc146pqapkln"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-algorithm-diff" ,perl-algorithm-diff)
-       ("perl-text-diff" ,perl-text-diff)))
+     (list perl-algorithm-diff perl-text-diff))
     (home-page "https://metacpan.org/release/Test-Files")
     (synopsis "Ease software testing with files and directories")
     (description "This library provides functions to enable testing of files
@@ -791,8 +768,7 @@ you test against long strings.")
                 "1n9jscnni24sbp4v5gjlcy3iknfwvmy0731xwvk1c3jq3kbslym4"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-test-pod" ,perl-test-pod)
-       ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
+     (list perl-test-pod perl-test-pod-coverage))
     (home-page "https://metacpan.org/release/Test-Manifest")
     (synopsis "Interact with a t/test_manifest file")
     (description "@code{Test::Manifest} overrides the default test file order.  Instead of
@@ -817,9 +793,9 @@ It constructs the right value for the build system to do the right thing.")
          "00ijmgx1r3cxrcs1qa9rb2s4gbm3nsawd90drda89kb4r7yxslwx"))))
     (build-system perl-build-system)
     (inputs
-     `(("perl-padwalker" ,perl-padwalker)))
+     (list perl-padwalker))
     (propagated-inputs
-     `(("perl-devel-cycle" ,perl-devel-cycle)))
+     (list perl-devel-cycle))
     (home-page
      "https://metacpan.org/release/Test-Memory-Cycle")
     (synopsis
@@ -840,23 +816,21 @@ memory_cycle_ok( $object );
 (define-public perl-test-mockmodule
   (package
     (name "perl-test-mockmodule")
-    (version "0.171.0")
+    (version "0.177.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://cpan/authors/id/G/GF/GFRANKS/"
                            "Test-MockModule-v" version ".tar.gz"))
        (sha256
-        (base32 "1arqgb1773zym5dqlwm6kz48bfrccjhb5bjfsif0vkalwq2gvm7b"))))
+        (base32 "0i8hiw9r2kak8kgp2qabr0cnnpp1yg1sddm781nhfxpavi4pmnhv"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-module-build" ,perl-module-build)
-       ;; For tests.
-       ("perl-test-pod" ,perl-test-pod)
-       ("perl-test-pod-coverage" ,perl-test-pod-coverage)
-       ("perl-test-warnings" ,perl-test-warnings)))
+     (list perl-module-build
+           ;; For tests.
+           perl-test-pod perl-test-pod-coverage perl-test-warnings))
     (propagated-inputs
-     `(("perl-super" ,perl-super)))
+     (list perl-super))
     (home-page "https://metacpan.org/release/Test-MockModule")
     (synopsis "Override subroutines in a module for unit testing")
     (description
@@ -881,14 +855,10 @@ you @code{unmock()} the subroutine.")
         (base32 "160r36j727hw6syazh6sfq862f95dp1zcga0nil7cjlry77lqsn7"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-cgi" ,perl-cgi)
-       ("perl-test-exception" ,perl-test-exception)
-       ("perl-test-warn" ,perl-test-warn)))
+     (list perl-cgi perl-test-exception perl-test-warn))
     (propagated-inputs
-     `(("perl-test-exception" ,perl-test-exception)
-       ("perl-test-warn" ,perl-test-warn)
-       ("perl-universal-can" ,perl-universal-can)
-       ("perl-universal-isa" ,perl-universal-isa)))
+     (list perl-test-exception perl-test-warn perl-universal-can
+           perl-universal-isa))
     (home-page "https://metacpan.org/release/Test-MockObject")
     (synopsis "Emulate troublesome interfaces in Perl")
     (description "Test::MockObject allows you to create objects that conform
@@ -908,7 +878,7 @@ the behavior, just the input and the output.")
        (sha256
         (base32 "1y820qsq7yf7r6smy5c6f0mpf2cis2q24vwmpim1svv0n8cf2qrk"))))
     (propagated-inputs
-     `(("perl-time-piece" ,perl-time-piece)))
+     (list perl-time-piece))
     (build-system perl-build-system)
     (home-page "https://metacpan.org/release/Test-MockTime")
     (synopsis "Replaces actual time with simulated time")
@@ -956,11 +926,8 @@ easy use flagged strings without warnings like \"Wide character in print
          "0zv5dyzq55r28plffibcr7wd00abap0h2zh4s4p8snaiszsad5wq"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-test-differences" ,perl-test-differences)
-       ("perl-test-warn" ,perl-test-warn)
-       ("perl-exception-class" ,perl-exception-class)
-       ("perl-test-deep" ,perl-test-deep)
-       ("perl-test-exception" ,perl-test-exception)))
+     (list perl-test-differences perl-test-warn perl-exception-class
+           perl-test-deep perl-test-exception))
     (home-page "https://metacpan.org/release/Test-Most")
     (synopsis "Most commonly needed test functions and features")
     (description "This module provides the most commonly used testing
@@ -971,7 +938,7 @@ bit more fine-grained control over test suites.")
 (define-public perl-test-needs
   (package
     (name "perl-test-needs")
-    (version "0.002005")
+    (version "0.002009")
     (source
      (origin
        (method url-fetch)
@@ -981,7 +948,7 @@ bit more fine-grained control over test suites.")
              ".tar.gz"))
        (sha256
         (base32
-         "16gkgpmr9hvkz382iaqd3500269lk2d44fqaw3dsrvc66nc36kss"))))
+         "1hsagkxw0b0xf9qk4i4c74dkjskrk23jcsxhb3graqfi78cj272p"))))
     (build-system perl-build-system)
     (home-page
      "https://metacpan.org/release/Test-Needs")
@@ -1034,7 +1001,7 @@ code.")
     (build-system perl-build-system)
     (synopsis "Ensure no warnings are produced while testing")
     (description
-     "This modules causes any warnings during testing to be captured and
+     "This module causes any warnings during testing to be captured and
 stored.  It automatically adds an extra test that will run when your script
 ends to check that there were no warnings.  If there were any warnings, the
 test will fail and output diagnostics of where, when and what the warning was,
@@ -1106,8 +1073,7 @@ classes in its inheritance tree in one single call.")
                 "0vjm62c7g3xxs3h4lba55dnpr4pg71yrhkdg5b9glxdh80klia7n"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-capture-tiny" ,perl-capture-tiny)
-       ("perl-sub-exporter" ,perl-sub-exporter)))
+     (list perl-capture-tiny perl-sub-exporter))
     (synopsis "Utilities to test STDOUT and STDERR messages")
     (description
      "Test::Output provides a simple interface for testing output sent to
@@ -1129,7 +1095,7 @@ as flexible as possible to the tester.")
         (base32
          "1z75x1pxwp8ajwq9iazlg2c3wd7rdlim08yclpdg32qnc36dpa30"))))
     (build-system perl-build-system)
-    (native-inputs `(("perl-module-build" ,perl-module-build)))
+    (native-inputs (list perl-module-build))
     (home-page "https://metacpan.org/release/Test-Pod")
     (synopsis "Check for POD errors in files")
     (description "Check POD files for errors or warnings in a test file, using
@@ -1150,7 +1116,7 @@ Pod::Simple to do the heavy lifting.")
          "1m203mhgfilz7iqc8mxaw4lw02fz391mni3n25sfx7nryylwrja8"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-pod-coverage" ,perl-pod-coverage)))
+     (list perl-pod-coverage))
     (home-page "https://metacpan.org/release/Test-Pod-Coverage")
     (synopsis "Check for pod coverage")
     (description "This module adds a test to your Perl distribution which
@@ -1170,9 +1136,9 @@ checks for pod coverage of all appropriate files.")
         (base32 "05hs80gljkd6mhb8zvilyk3pjqxp5samgnymam5v9h9d94rb9r08"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-test-simple" ,perl-test-simple)))
+     (list perl-test-simple))
     (propagated-inputs
-     `(("perl-pathtools" ,perl-pathtools)))
+     (list perl-pathtools))
     (home-page "https://metacpan.org/dist/Test-Portability-Files")
     (synopsis "Check file names portability")
     (description "Test::Portability::Files module is used to check the
@@ -1240,14 +1206,14 @@ reported, and the tests skipped.")
          "1mnym49j1lj7gzylma5b6nr4vp75rmgz2v71904v01xmxhy9l4i1"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-capture-tiny" ,perl-capture-tiny)))
+     (list perl-capture-tiny))
     (propagated-inputs
-     `(("perl-indirect" ,perl-indirect)
-       ("perl-moo" ,perl-moo)
-       ("perl-moox-types-mooselike" ,perl-moox-types-mooselike)
-       ("perl-multidimensional" ,perl-multidimensional)
-       ("perl-strictures" ,perl-strictures)
-       ("perl-sub-install" ,perl-sub-install)))
+     (list perl-indirect
+           perl-moo
+           perl-moox-types-mooselike
+           perl-multidimensional
+           perl-strictures
+           perl-sub-install))
     (home-page "https://metacpan.org/release/Test-Roo")
     (synopsis "Composable, reusable tests with roles and Moo")
     (description "Test::Roo provides composable, reusable tests with roles.")
@@ -1268,11 +1234,9 @@ reported, and the tests skipped.")
         (base32 "1vm5iw5sy0mhjjypaaviil9qgqixmkaghdbjbcyb4lf2mm6d24v9"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-module-build" ,perl-module-build)))
+     (list perl-module-build))
     (propagated-inputs
-     `(("perl-path-tiny" ,perl-path-tiny)
-       ("perl-test-trap" ,perl-test-trap)
-       ("valgrind" ,valgrind)))
+     (list perl-path-tiny perl-test-trap valgrind))
     (home-page "https://metacpan.org/release/Test-RunValgrind")
     (synopsis "Tests that an external program is valgrind-clean")
     (description "Test::RunValgind checks weather Valgrind does not detect
@@ -1292,8 +1256,7 @@ errors (such as memory leaks) in an arbitrary binary executable.")
                 "1msavbi6przkxq3npm90nv925v58iym9jrk677wn46x19whwzwzm"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-capture-tiny" ,perl-capture-tiny)
-       ("perl-probe-perl" ,perl-probe-perl)))
+     (list perl-capture-tiny perl-probe-perl))
     (synopsis "Basic cross-platform tests for scripts")
     (description
      "The intent of the Test::Script module is to provide a series of basic
@@ -1315,7 +1278,7 @@ bin as is also commonly used) paths of your Perl distribution.")
         (base32 "17y52j20k1bs9dgf4n6rhh9dn4cfxxbnfn2cfs7pb00fc5jyhci9"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-test-requires" ,perl-test-requires)))
+     (list perl-test-requires))
     (home-page "https://metacpan.org/release/Test-SharedFork")
     (synopsis "Fork test in Perl")
     (description "Test::SharedFork is a utility module for Test::Builder.  It
@@ -1353,7 +1316,7 @@ makes fork(2) safe to use in test cases.")
         (base32 "1hmnv9nkdzyrr6yis0dnkf4lk0hwld3zapiyq7mizrq5barykhfb"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-hook-lexwrap" ,perl-hook-lexwrap)))
+     (list perl-hook-lexwrap))
     (home-page "https://metacpan.org/release/Test-SubCalls")
     (synopsis "Track the number of times subs are called")
     (description
@@ -1427,10 +1390,7 @@ a minimum of effort.")
          "1j5rsb4km9rzcbd1ljavj8vm42bmilji40v2jj2k87l1ykrxj59z"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-file-finder" ,perl-file-finder)
-       ("perl-file-slurp" ,perl-file-slurp)
-       ("perltidy" ,perltidy)
-       ("perl-text-diff" ,perl-text-diff)))
+     (list perl-file-finder perl-file-slurp perltidy perl-text-diff))
     (home-page "https://metacpan.org/release/Test-PerlTidy")
     (synopsis "Check that all your Perl files are tidy")
     (description
@@ -1451,10 +1411,9 @@ cause a test fail unless it is exactly as @code{perltidy} would like it to be.")
         (base32 "1qjs2080kcc66s4d7499br5lw2qmhr9gxky4xsl6vjdn6dpna10b"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-module-build" ,perl-module-build)
-       ("perl-test-simple" ,perl-test-simple)))
+     (list perl-module-build perl-test-simple))
     (propagated-inputs
-     `(("perl-data-dump" ,perl-data-dump)))
+     (list perl-data-dump))
     (home-page "https://metacpan.org/release/Test-Trap")
     (synopsis "Trap exit codes, exceptions, output, and so on")
     (description "This module is primarily (but not exclusively) for use in
@@ -1476,7 +1435,7 @@ from boxed blocks of test code.")
         (base32 "1mwbdgbbzm54v7wdw3l80bk73lr4z9i8274zlhjhp0s0b6fg10nz"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-module-install" ,perl-module-install)))
+     (list perl-module-install))
     (home-page "https://metacpan.org/release/Test-utf8")
     (synopsis "UTF-8 testing in Perl")
     (description "This module is a collection of tests useful for dealing with
@@ -1501,9 +1460,9 @@ will check that string has a given set of characteristics.")
          "1q1qradaf7r2rb3jhpv01wl8z3bxymkfqrl9gwdhxwx5jwldvqcw"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-test-exception" ,perl-test-exception)))
+     (list perl-test-exception))
     (propagated-inputs
-     `(("perl-file-find-rule-perl" ,perl-file-find-rule-perl)))
+     (list perl-file-find-rule-perl))
     (home-page "https://metacpan.org/release/Test-Version")
     (synopsis "Check versions in modules")
     (description
@@ -1525,7 +1484,7 @@ defined, and that the version is valid.")
          "1nkc7jzxff0w4x9axbpsgxrksqdjnf70rb74q39zikkrsd3a7g7c"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-sub-uplevel" ,perl-sub-uplevel)))
+     (list perl-sub-uplevel))
     (home-page "https://metacpan.org/release/Test-Warn")
     (synopsis "Perl extension to test methods for warnings")
     (description "This module provides a few convenience methods for testing
@@ -1588,13 +1547,10 @@ installed.")
         (base32 "11v4j3607bydxsqy2ylx9w6qr3qxcalfx3mdc4q4ccqmxsyw4jb3"))))
     (build-system perl-build-system)
     (native-inputs
-     `(("perl-test-most" ,perl-test-most)
-       ("perl-test-directory" ,perl-test-directory)))
+     (list perl-test-most perl-test-directory))
     (propagated-inputs
-     `(("perl-data-tumbler" ,perl-data-tumbler)
-       ("perl-file-homedir" ,perl-file-homedir)
-       ("perl-module-pluggable" ,perl-module-pluggable)
-       ("perl-module-runtime" ,perl-module-runtime)))
+     (list perl-data-tumbler perl-file-homedir perl-module-pluggable
+           perl-module-runtime))
     (home-page "https://metacpan.org/release/Test-WriteVariants")
     (synopsis "Dynamic generation of tests")
     (description "The Test::WriteVariants module provides for the dynamic
@@ -1614,7 +1570,7 @@ generation of tests in nested combinations of contexts.")
         (base32 "0pwrrnwi1qaiy3c5522vy0kzncxc9g02r4b056wqqaa69w1hsc0z"))))
     (build-system perl-build-system)
     (propagated-inputs
-     `(("perl-test-base" ,perl-test-base)))
+     (list perl-test-base))
     (home-page "https://metacpan.org/release/Test-YAML")
     (synopsis "Testing module for YAML implementations")
     (description "Test::YAML is a subclass of Test::Base with YAML specific
@@ -1637,13 +1593,9 @@ support.")
           "04aszaw4n3sra7n7sq2cj4wjjvfghia9zqi47aj00ry0vqx2d7gh"))))
   (build-system perl-build-system)
   (native-inputs
-    `(("perl-module-build" ,perl-module-build)
-      ("perl-file-find-object" ,perl-file-find-object)
-      ("perl-class-xsaccessor" ,perl-class-xsaccessor)))
+    (list perl-module-build perl-file-find-object perl-class-xsaccessor))
   (inputs
-    `(("perl-file-find-object-rule" ,perl-file-find-object-rule)
-      ("perl-text-glob" ,perl-text-glob)
-      ("perl-number-compare" ,perl-number-compare)))
+    (list perl-file-find-object-rule perl-text-glob perl-number-compare))
   (home-page
     "https://metacpan.org/release/Test-TrailingSpace")
   (synopsis