summary refs log tree commit diff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm17
1 files changed, 5 insertions, 12 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index c498703205..1e78c8e9fe 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -9,7 +9,7 @@
 ;;; Copyright © 2020 Sebastian Schott <sschott@mailbox.org>
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020. 2021, 2022 Vinicius Monego <monego@posteo.net>
-;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -459,7 +459,7 @@ photographic equipment.")
 (define-public darktable
   (package
     (name "darktable")
-    (version "4.2.1")
+    (version "4.4.1")
     (source
      (origin
        (method url-fetch)
@@ -467,7 +467,7 @@ photographic equipment.")
              "https://github.com/darktable-org/darktable/releases/"
              "download/release-" version "/darktable-" version ".tar.xz"))
        (sha256
-        (base32 "1b3vr6njwqfvnrx3qpbg5aqcbl1z8nxnxcgyyw0sd4a20z33jfk0"))))
+        (base32 "038gdri1mcmq9mlaikq5x9xyrs20b99jpcchfspngnwa5s6x6hz0"))))
     (build-system cmake-build-system)
     (arguments
      (list
@@ -484,13 +484,6 @@ photographic equipment.")
                  (string-append "\""
                                 (search-input-file inputs "/lib/libOpenCL.so")
                                 "\"")))))
-          (add-after 'unpack 'fix-missing-include
-            (lambda _
-              ;; Fix missing include needed to build tests.  See upstream
-              ;; issue: https://github.com/darktable-org/darktable/issues/12604
-              (substitute* "./src/common/variables.h"
-                (("once")
-                 "once\n#include \"common/image.h\""))))
           (add-before 'configure 'prepare-build-environment
             (lambda _
               ;; Rawspeed fails to build with GCC due to OpenMP error:
@@ -514,13 +507,13 @@ photographic equipment.")
                   (,(string-append #$(this-package-input "gtk+")
                                    "/share/glib-2.0/schemas")))))))))
     (native-inputs
-     (list clang-11
+     (list clang
            cmocka
            desktop-file-utils
            `(,glib "bin")
            gobject-introspection
            intltool
-           llvm-11                      ;should match the Clang version
+           llvm                         ;should match the Clang version
            opencl-headers
            perl
            pkg-config