summary refs log tree commit diff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index e525a55fc6..f66e3469b8 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -285,9 +285,6 @@ language-neutral, platform-neutral extensible mechanism for serializing
 structured data.")
     (license license:expat)))
 
-(define-public python2-protobuf
-  (package-with-python2 python-protobuf))
-
 ;; For tensorflow.
 (define-public python-protobuf-3.6
   (package
@@ -300,7 +297,10 @@ structured data.")
        (uri (pypi-uri "protobuf" version))
        (sha256
         (base32
-         "04bqb12smlckzmgkj6vgmpbr3cby0n6726cmz33bqr7kn1vb728l"))))))
+         "04bqb12smlckzmgkj6vgmpbr3cby0n6726cmz33bqr7kn1vb728l"))))
+    (inputs
+     (cons python-six
+           (package-inputs python-protobuf)))))
 
 (define-public python-proto-plus
   (package