summary refs log tree commit diff
path: root/gnu/packages/purescript.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/purescript.scm')
-rw-r--r--gnu/packages/purescript.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/purescript.scm b/gnu/packages/purescript.scm
index df9267692a..ef58ecbf82 100644
--- a/gnu/packages/purescript.scm
+++ b/gnu/packages/purescript.scm
@@ -26,6 +26,7 @@
   #:use-module (gnu packages haskell-web)
   #:use-module ((gnu packages python) #:select (python))
   #:use-module (guix download)
+  #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module (guix build-system haskell)
@@ -34,13 +35,13 @@
 (define-public purescript
   (package
     (name "purescript")
-    (version "0.15.9")
+    (version "0.15.10")
     (source
      (origin
        (method url-fetch)
        (uri (hackage-uri "purescript" version))
        (sha256
-        (base32 "1i9wszs5kwwq0l8l4if05y8xc8fih10assrdj8q1ipr0hx3zjawm"))))
+        (base32 "08pashk8pm4yjsaq2g94sqa2yd3rfq9fwpxa9qccvjv6in9zybf1"))))
     (build-system haskell-build-system)
     (properties '((upstream-name . "purescript")))
     (inputs (list ghc-aeson
@@ -96,21 +97,23 @@
                          ghc-typed-process
                          ghc-happy))
     (arguments
-     `(;; Tests require npm
-       #:tests? #f
-       #:configure-flags '("--flags=release")
+     (list
+      ;; Tests require npm
+      #:tests? #f
+       #:configure-flags
+       #~(list "--flags=release")
        #:haddock? #f
        #:phases
-       (modify-phases %standard-phases
+       #~(modify-phases %standard-phases
          (add-before 'configure 'update-constraints
            (lambda _
              (substitute* "purescript.cabal"
                (("\\b(language-javascript|process)\\s+[^,]+" all dep)
                 dep))))
          (add-after 'register 'remove-libraries
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda _
              (delete-file-recursively
-               (string-append (assoc-ref outputs "out") "/lib")))))))
+               (string-append #$output "/lib")))))))
     (home-page "https://www.purescript.org/")
     (synopsis "Haskell inspired programming language compiling to JavaScript")
     (description