summary refs log tree commit diff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm31
1 files changed, 19 insertions, 12 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bfbae3ce07..80ed6a27b1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7067,17 +7067,22 @@ provides well-defined APIs to talk to websites lacking one.")
         (base32 "07fhcjiyif80z1vyh35za29sqx1mmqh568jrbrrs675j4a797sj1"))))
     (build-system python-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'loosen-requirements
-                    (lambda _
-                      ;; Don't pin specific versions of dependencies.
-                      (substitute* "requirements.txt"
-                        (("^sqlalchemy[=<>].*") "sqlalchemy\n")
-                        (("^marshmallow[=<>].*") "marshmallow\n")
-                        (("^Flask[=<>].*") "Flask\n"))))
-                  (replace 'check
-                    (lambda _
-                      (invoke "pytest" "-vv"))))))
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'loosen-requirements
+           (lambda _
+             ;; Don't pin specific versions of dependencies.
+             (substitute* "requirements.txt"
+               (("^sqlalchemy[=<>].*") "sqlalchemy\n")
+               (("^marshmallow[=<>].*") "marshmallow\n")
+               (("^Flask[=<>].*") "Flask\n"))))
+         (replace 'check
+           (lambda _
+             (invoke "pytest" "-vv" "-k"
+                     ;; The following test fails for unknown reasons (see:
+                     ;; https://github.com/AdCombo/flask-combo-jsonapi/issues/66).
+                     "not test_get_list_with_simple_filter_\
+relationship_custom_qs_api"))))))
     (propagated-inputs
      (list python-flask
            python-marshmallow
@@ -7088,7 +7093,9 @@ provides well-defined APIs to talk to websites lacking one.")
            python-simplejson
            python-six))
     (native-inputs
-     (list python-coverage python-coveralls python-pytest
+     (list python-coverage
+           python-coveralls
+           python-pytest
            python-pytest-runner))
     (home-page "https://github.com/AdCombo/flask-combo-jsonapi")
     (synopsis "Flask extension to quickly create JSON:API 1.0 REST Web APIs")