summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index dd1b4a64f2..95898c31da 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24837,13 +24837,13 @@ project.")
 (define-public python-trio
   (package
     (name "python-trio")
-    (version "0.22.0")
+    (version "0.21.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "trio" version))
        (sha256
-        (base32 "1kxa9v0cds0xnklvzppv4ix4xg81r73p5pm4qlvv2iqa832z2s6f"))))
+        (base32 "04qwzy4295ajxpns0hrmn3asma80sjpimzpb3i877vwynsvkjgsj"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -24876,6 +24876,8 @@ _cyclic_garbage"
                          " and not test_locals_destroyed_promptly_on_cancel"
                          " and not test_ipython_exc_handler"
                          " and not test_for_leaking_fds"
+                         ;; Signals don’t work in the build sandbox.
+                         " and not test_open_signal_receiver"
                          ;; These try to raise KeyboardInterrupt which does not work
                          ;; in the build environment.
                          " and not test_ki_self"