summary refs log tree commit diff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a806166569..e486a73023 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2666,6 +2666,7 @@ Unicode-to-LaTeX conversion.")
        (file-name (git-file-name name version))
        (sha256
         (base32 "0bkhfnlik89j3yamr20br4wm8975f20v33wabi2nyxvj10whr5dj"))
+       (patches (search-patches "python-pyls-black-41.patch"))
        ;; Patch to work with python-lsp-server.  Taken from
        ;; <https://github.com/rupert/pyls-black/pull/37>.
        (modules '((guix build utils)))
@@ -2681,9 +2682,11 @@ Unicode-to-LaTeX conversion.")
               "pylsp_format_range")
              (("from pyls([ \\.])" _ char)
               (string-append "from pylsp" char)))))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     `(#:test-target "pytest"))
+     (list
+      #:test-flags
+      '(list "-k" "not test_load_config_target_version")))
     (propagated-inputs
      (list python-black python-lsp-server python-tomli))
     (native-inputs