summary refs log tree commit diff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 85b75c17d6..f432709c19 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -287,6 +287,14 @@ cards.")
                      (("^doc:.*") "doc:\n")
                      (("install-podboat install-docs") "install-podboat")))))
              '())
+         (add-after 'unpack 'pre-build
+           (lambda* (#:key inputs #:allow-other-keys)
+             (setenv "CXX" ,(cxx-for-target))
+             (setenv "CXX_FOR_BUILD" (which "g++"))
+             (substitute* "config.sh"
+               (("if curl-config")
+                (string-append
+                  "if " (search-input-file inputs "/bin/curl-config"))))))
          (add-after 'configure 'dont-vendor-self
            (lambda* (#:key vendor-dir #:allow-other-keys)
              ;; Don't keep the whole tarball in the vendor directory
@@ -301,9 +309,10 @@ cards.")
          (replace 'build
            (assoc-ref gnu:%standard-phases 'build))
          (replace 'check
-           (lambda args
-             ((assoc-ref gnu:%standard-phases 'check)
-              #:test-target "test")))
+           (lambda* (#:key tests? #:allow-other-keys #:rest args)
+             (when tests?
+               ((assoc-ref gnu:%standard-phases 'check)
+                #:test-target "test"))))
          (replace 'install
            (assoc-ref gnu:%standard-phases 'install)))))
     (native-search-paths