summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 17 insertions, 11 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8cc1020e1a..8f7f1fa42f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5641,23 +5641,29 @@ of which make use of the @code{stackengine} core.")
 
 (define-deprecated-package texlive-latex-stackengine texlive-stackengine)
 
-(define-public texlive-latex-tocloft
+(define-public texlive-tocloft
   (package
-    (inherit (simple-texlive-package
-              "texlive-latex-tocloft"
-              '("/doc/latex/tocloft/" "/tex/latex/tocloft/")
-              (base32
-               "0mg3hpzq7wpm6mnnvb0rp3wby56zyxkyai8d2h3f4vk93zrc6awk")
-              #:trivial? #t))
+    (name "texlive-tocloft")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/tocloft/"
+                   "source/latex/tocloft/"
+                   "tex/latex/tocloft/")
+             (base32
+              "1s09g02pq2zi5ywm3yhyp4lpzq77n9aahr6wnm1c0wb9zawq2mpk")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
     (home-page "https://www.ctan.org/pkg/tocloft")
     (synopsis "Control table of contents")
     (description
-     "This package provides control over the typography of the
-@dfn{Table of Contents}, @dfn{List of Figures} and @dfn{List of Tables},
-and the ability to create new ‘List of ...’. The ToC @code{\\parskip} may
-be changed.")
+     "This package provides control over the typography of the @dfn{Table of
+Contents}, @dfn{List of Figures} and @dfn{List of Tables}, and the ability to
+create new @samp{List of ...}.  The ToC @code{\\parskip} may be changed.")
     (license license:lppl1.3c+)))
 
+(define-deprecated-package texlive-latex-tocloft texlive-tocloft)
+
 (define-public texlive-trimspaces
   (package
     (name "texlive-trimspaces")