summary refs log tree commit diff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 49e38e051c..b03c3417e5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6434,6 +6434,29 @@ definition capability, new drawing commands can be constructed from drawing
 segments.")
     (license license:cc-by4.0)))
 
+(define-public texlive-texfot
+  (package
+    (name "texlive-texfot")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/texfot.1"
+                   "doc/man/man1/texfot.man1.pdf"
+                   "doc/support/texfot/" "scripts/texfot/")
+             (base32
+              "0cy1fz265ch13cn0jwfg7rlspqlxv8swnv6ljjvqqg8hbl390npd")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:link-scripts #~(list "texfot.pl")))
+    (inputs (list perl))
+    (home-page "https://ctan.org/pkg/texfot")
+    (synopsis "Filter clutter from the output of a TeX run")
+    (description
+     "The package provides a small Perl script to filter the online output
+from a TeX run, attempting to show only those messages which probably deserve
+some change in the source.  The TeX invocation itself need not change.")
+    (license license:public-domain)))
+
 (define-public texlive-ticollege
   (package
     (name "texlive-ticollege")