summary refs log tree commit diff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 2264e3ccb6..151add964e 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -210,11 +210,11 @@ normalization, case-folding, and other operations for data in the UTF-8
 encoding, supporting Unicode version 9.0.0.")
     (license license:expat)))
 
-(define-public utf8proc-2.6.1
+(define-public utf8proc-2.7.0
   (package
     (inherit utf8proc)
     (name "utf8proc")
-    (version "2.6.1")
+    (version "2.7.0")
     (source
      (origin
        (method git-fetch)
@@ -223,7 +223,7 @@ encoding, supporting Unicode version 9.0.0.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1zqc6airkzkssbjxanx5v8blfk90180gc9id0dx8ncs54f1ib8w7"))))
+        (base32 "1wrsmnaigal94gc3xbzdrrm080zjhihjfdla5admllq2w5dladjj"))))
     (arguments
      (substitute-keyword-arguments (package-arguments utf8proc)
        ((#:phases phases)
@@ -239,14 +239,14 @@ encoding, supporting Unicode version 9.0.0.")
     (native-inputs
      (append
       (package-native-inputs utf8proc)
-      (let ((UNICODE_VERSION "13.0.0"))
+      (let ((UNICODE_VERSION "14.0.0"))
         `(("DerivedCoreProperties.txt"
            ,(origin
               (method url-fetch)
               (uri (string-append "https://www.unicode.org/Public/"
                                   UNICODE_VERSION "/ucd/DerivedCoreProperties.txt"))
               (sha256
-               (base32 "0j12x112cd8fpgazkc8izxnhhpia44p1m36ff8yapslxndcmzm55"))))
+               (base32 "1g77s8g9443dd92f82pbkim7rk51s7xdwa3mxpzb1lcw8ryxvvg3"))))
           ;; For tests
           ("ruby" ,ruby)))))))