summary refs log tree commit diff
path: root/gnu/packages/webkit.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/webkit.scm')
-rw-r--r--gnu/packages/webkit.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/webkit.scm b/gnu/packages/webkit.scm
index f1b810adbd..f47fff25d2 100644
--- a/gnu/packages/webkit.scm
+++ b/gnu/packages/webkit.scm
@@ -199,6 +199,13 @@ engine that uses Wayland for graphics output.")
                 (substitute* "Source/WebKit/UIProcess/glib/WebProcessPoolGLib.cpp"
                   (("libWPEBackend-fdo-[\\.0-9]+\\.so" all)
                    (search-input-file inputs (string-append "lib/" all)))))))
+          #$@(if (target-x86-32?)
+                 ;; Don't include x86intrin.h on i686-linux.
+                 '((add-after 'unpack 'fix-headers
+                     (lambda _
+                       (substitute* "Source/ThirdParty/ANGLE/src/common/platform.h"
+                         (("\\|\\| defined\\(__i386__\\)") "")))))
+                 '())
           #$@(if (target-x86-64?)
                  '()
                  '((add-after 'unpack 'disable-sse2
@@ -222,7 +229,7 @@ engine that uses Wayland for graphics output.")
            pkg-config
            python-wrapper
            gi-docgen
-           ruby
+           ruby-2.7
            unifdef))
     (propagated-inputs
      (list gtk+ libsoup))