summary refs log tree commit diff
path: root/gnu/packages/wm.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/wm.scm')
-rw-r--r--gnu/packages/wm.scm27
1 files changed, 25 insertions, 2 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index b9909de219..f2c050408e 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2022,6 +2022,29 @@ automatically enabled and disabled on hotplug.  Kanshi can be used with
 Wayland compositors supporting the wlr-output-management protocol.")
     (license license:expat))) ; MIT license
 
+(define-public wdisplays
+  (package
+    (name "wdisplays")
+    (version "1.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/artizirk/wdisplays.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "06ydcmfdics2qqjb14p767xs8khd86nancdd9z8j11h2gpvwznvn"))))
+    (build-system meson-build-system)
+    (inputs (list gtk+ libepoxy wayland))
+    (native-inputs (list `(,glib "bin") pkg-config))
+    (home-page "https://github.com/artizirk/wdisplays")
+    (synopsis "Configuring displays in Wayland compositors")
+    (description "@command{wdisplays} is a graphical application for
+configuring displays in Wayland compositors that implements the
+wlr-output-management-unstable-v1 protocol.")
+    (license license:gpl3+)))
+
 (define-public stumpwm
   (package
     (name "stumpwm")
@@ -2876,7 +2899,7 @@ read and write, and compatible with JSON.")
 (define-public labwc
   (package
     (name "labwc")
-    (version "0.6.3")
+    (version "0.6.4")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2885,7 +2908,7 @@ read and write, and compatible with JSON.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1zbgj8r8ppvqnz2imh6f825f2lvsqpiqfa0r5g5r4nsvadiipivp"))))
+                "00ajr7s8qywdfa9vhlfc02p1wwdcqaaa09pm1im9w6mrvb904lzh"))))
     (build-system meson-build-system)
     (native-inputs
      (list pkg-config gettext-minimal scdoc))