summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 416208707e..383d4d1618 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9150,7 +9150,16 @@ anti-fragmentation protection.")
         (base32 "12qwx0yk7wjj25v4fswgmj28r69gk94kqdmzavca8k9f0yznniz1"))))
     (build-system go-build-system)
     (arguments
-     '(#:import-path "github.com/valyala/fasthttp"))
+     (list
+       #:import-path "github.com/valyala/fasthttp"
+       #:phases
+       #~(modify-phases %standard-phases
+           (replace 'check
+             (lambda* (#:key inputs #:allow-other-keys #:rest args)
+               (unless
+                 ;; Tests hang forever with gccgo.
+                 (false-if-exception (search-input-file inputs "/bin/gccgo"))
+                 (apply (assoc-ref %standard-phases 'check) args)))))))
     (propagated-inputs
      (list go-golang-org-x-sys
            go-golang-org-x-net