summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm44
1 files changed, 21 insertions, 23 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 5a027b5af7..82987d5f9c 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -365,29 +365,27 @@ them in order to efficiently transfer a minimal amount of data.")
     (build-system meson-build-system)
     (outputs '("out" "doc" "gst" "tools"))
     (arguments
-     `(#:glib-or-gtk? #t     ; To wrap binaries and/or compile schemas
-       #:configure-flags
-       (list
-        (string-append "-Dbindir=" (assoc-ref %outputs "tools") "/bin")
-        "-Dtest=true"
-        "-Dv4l2=true"
-        ;; XXX: Requires bundled pybind11.
-        "-Dpycamera=disabled")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'install 'move-doc-and-gst
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (doc (assoc-ref outputs "doc"))
-                    (gst (assoc-ref outputs "gst")))
-               (mkdir-p (string-append doc "/share"))
-               (rename-file
-                (string-append out "/share/doc")
-                (string-append doc "/share/doc"))
-               (mkdir-p (string-append gst "/lib"))
-               (rename-file
-                (string-append out "/lib/gstreamer-1.0")
-                (string-append gst "/lib/gstreamer-1.0"))))))))
+     (list #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+           #:configure-flags
+           #~(list (string-append "-Dbindir="
+                                  (assoc-ref %outputs "tools") "/bin")
+                   "-Dtest=true" "-Dv4l2=true"
+                   ;; XXX: Requires bundled pybind11.
+                   "-Dpycamera=disabled")
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'install 'move-doc-and-gst
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (let* ((out (assoc-ref outputs "out"))
+                          (doc (assoc-ref outputs "doc"))
+                          (gst (assoc-ref outputs "gst")))
+                     (mkdir-p (string-append doc "/share"))
+                     (rename-file (string-append out "/share/doc")
+                                  (string-append doc "/share/doc"))
+                     (mkdir-p (string-append gst "/lib"))
+                     (rename-file
+                      (string-append out "/lib/gstreamer-1.0")
+                      (string-append gst "/lib/gstreamer-1.0"))))))))
     (native-inputs
      (list googletest
            graphviz                     ;for 'dot'