summary refs log tree commit diff
path: root/gnu/packages
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/crates-io.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e83902fcde..1fd98fd58c 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -61342,6 +61342,42 @@ sub-processes using a fork-like interface.")
        (("rust-quote" ,rust-quote-1)
         ("rust-syn" ,rust-syn-1))))))
 
+(define-public rust-ruzstd-0.4
+  (package
+    (name "rust-ruzstd")
+    (version "0.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "ruzstd" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1p4ghqzkq36dy1x1ijnk7jmml4wi3v9bkfzlbm2hsnkiz6wglgxc"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-test-flags
+       '("--release" "--"
+         ;; not all files included
+         "--skip=tests::decode_corpus::test_decode_corpus_files"
+         "--skip=tests::dict_test::test_dict_decoding"
+         "--skip=tests::fuzz_regressions::test_all_artifacts"
+         "--skip=tests::test_block_header_reading"
+         "--skip=tests::test_decode_from_to"
+         "--skip=tests::test_frame_decoder"
+         "--skip=tests::test_frame_header_reading"
+         "--skip=tests::test_specific_file"
+         "--skip=tests::test_streaming")
+       #:cargo-inputs (("rust-byteorder" ,rust-byteorder-1)
+                       ("rust-thiserror-core" ,rust-thiserror-core-1)
+                       ("rust-twox-hash" ,rust-twox-hash-1))
+       #:cargo-development-inputs (("rust-criterion" ,rust-criterion-0.3)
+                                   ("rust-rand" ,rust-rand-0.8))))
+    (home-page "https://github.com/KillingSpark/zstd-rs")
+    (synopsis "Decoder for the zstd compression format")
+    (description
+     "This package provides a decoder for the zstd compression format.")
+    (license license:expat)))
+
 (define-public rust-rkyv-0.7
   (package
     (name "rust-rkyv")