summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crypto.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 5989cc5991..3aef4d3135 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1552,36 +1552,37 @@ SHA-3, and BLAKE2.")
 (define-public rust-blake3-1
   (package
     (name "rust-blake3")
-    (version "1.0.0")
-    ;; The crate does not include the reference_impl directory.
+    (version "1.5.0")
     (source
      (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/BLAKE3-team/BLAKE3")
-             (commit version)))
-       (file-name (git-file-name name version))
+       (method url-fetch)
+       (uri (crate-uri "blake3" version))
+       (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32
-         "09xi7rjyi5hgxyfpias485x5argwqygvfl9sggiw221qjdfxpbdn"))))
+        (base32 "11ysh12zcqq6xkjxh5cbrmnwzalprm3z552i5ff7wm5za9hz0c82"))))
     (build-system cargo-build-system)
     (arguments
      (list
+      #:tests? #f       ; use of undeclared crate or module `reference_impl`
       #:cargo-inputs
       `(("rust-arrayref" ,rust-arrayref-0.3)
         ("rust-arrayvec" ,rust-arrayvec-0.7)
         ("rust-cc" ,rust-cc-1)
         ("rust-cfg-if" ,rust-cfg-if-1)
-        ("rust-constant-time-eq" ,rust-constant-time-eq-0.1)
-        ("rust-crypto-mac" ,rust-crypto-mac-0.11)
-        ("rust-digest" ,rust-digest-0.9)
-        ("rust-rayon" ,rust-rayon-1))
+        ("rust-constant-time-eq" ,rust-constant-time-eq-0.3)
+        ("rust-digest" ,rust-digest-0.10)
+        ("rust-memmap2" ,rust-memmap2-0.7)
+        ("rust-rayon" ,rust-rayon-1)
+        ("rust-serde" ,rust-serde-1)
+        ("rust-zeroize" ,rust-zeroize-1))
       #:cargo-development-inputs
-      `(("rust-cc" ,rust-cc-1)
-        ("rust-hex" ,rust-hex-0.4)
-        ("rust-page-size" ,rust-page-size-0.4)
+      `(("rust-hex" ,rust-hex-0.4)
+        ("rust-hmac" ,rust-hmac-0.12)
+        ("rust-page-size" ,rust-page-size-0.6)
         ("rust-rand" ,rust-rand-0.8)
-        ("rust-rand-chacha" ,rust-rand-chacha-0.3))))
+        ("rust-rand-chacha" ,rust-rand-chacha-0.3)
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-tempfile" ,rust-tempfile-3))))
     (home-page "https://github.com/BLAKE3-team/BLAKE3")
     (synopsis "BLAKE3 hash function Rust implementation")
     (description "This crate provides the official Rust implementation of the