summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm9
-rw-r--r--gnu/packages/patches/inetutils-syslogd.patch20
2 files changed, 2 insertions, 27 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 883f25d7c3..a96ce9cdfb 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -152,25 +152,20 @@ re-executing them as necessary.")
 (define-public inetutils
   (package
     (name "inetutils")
-    (version "1.9.2")
+    (version "1.9.3")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/inetutils/inetutils-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "04wrm0v7l4890mmbaawd6wjwdv08bkglgqhpz0q4dkb0l50fl8q4"))
-             (patches (list (search-patch "inetutils-syslogd.patch")))))
+               "06dshajjpyi9sxi7qfki9gnp5r3nxvyvf81r81gx0x2qkqzqcxlj"))))
     (build-system gnu-build-system)
     (arguments `(;; FIXME: `tftp.sh' relies on `netstat' from utils-linux,
                  ;; which is currently missing.
                  #:tests? #f))
     (inputs `(("ncurses" ,ncurses)
               ("readline" ,readline)))            ; for 'ftp'
-
-    ;; Help2man is needed because of the patch that modifies syslogd.c.
-    (native-inputs `(("help2man" ,help2man)))
-
     (home-page "http://www.gnu.org/software/inetutils/")
     (synopsis "Basic networking utilities")
     (description
diff --git a/gnu/packages/patches/inetutils-syslogd.patch b/gnu/packages/patches/inetutils-syslogd.patch
deleted file mode 100644
index 0bf9eb7fc6..0000000000
--- a/gnu/packages/patches/inetutils-syslogd.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-From <http://lists.gnu.org/archive/html/bug-inetutils/2015-04/msg00001.html>.
-
-2015-04-01  Ludovic Courtès  <ludo@gnu.org>
-
-	* src/syslogd.c (load_conffile): Use 'bcopy' instead of 'strcpy'
-	since the two regions may overlap.
-	Reported by Alex Kost <alezost@gmail.com>
-	at <http://lists.gnu.org/archive/html/guix-devel/2015-03/msg00780.html>.
-
---- a/src/syslogd.c
-+++ b/src/syslogd.c
-@@ -1989,7 +1989,7 @@ load_conffile (const char *filename, struct filed **nextp)
-       if (*p == '\0' || *p == '#')
- 	continue;
- 
--      strcpy (cline, p);
-+      bcopy (p, cline, strlen (p) + 1);
- 
-       /* Cut the trailing spaces.  */
-       for (p = strchr (cline, '\0'); isspace (*--p);)