summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 9925a72763..cc3a7c9641 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -772,7 +772,12 @@ more.")
                 "0yjzq12ivizp23y7zqm30x20psv9gzwbcdrhyd3f7h0ds94m1c40"))))
     (build-system cmake-build-system)
     (arguments
-     '(#:tests? #f))                    ; no test target
+     `(#:configure-flags
+       ;; Prevent two mostly-duplicate directories.  Use Guix's versioned
+       ;; default for licences instead of CGAL's unversioned one.
+       (list (string-append "-DCGAL_INSTALL_DOC_DIR=share/doc/"
+                            ,name "-" ,version))
+       #:tests? #f))                    ; no test target
     (inputs
      `(("mpfr" ,mpfr)
        ("gmp" ,gmp)