summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/pdf.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index ff7d895774..ddac5537f0 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -78,6 +78,7 @@
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages image)
   #:use-module (gnu packages javascript)
+  #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages lesstif)
   #:use-module (gnu packages libffi)
   #:use-module (gnu packages linux)
@@ -166,6 +167,33 @@ directly.  It uses LittleCMS for color management but otherwise does not
 convert data in any way.")
     (license license:asl2.0)))
 
+(define-public diffpdf
+  (let ((commit "ba68231d3d05e0cb3a2d4a4fca8b70d4044f4303")
+        (revision "1"))
+    (package
+      (name "diffpdf")
+      (version (git-version "2.1.3.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://gitlab.com/eang/diffpdf")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1vwgv28b291lrcs9fljnlbnicv16lwj4vvl4bz6w3ldp9n5isjmf"))))
+      (build-system cmake-build-system)
+      (arguments
+       `(#:tests? #f))
+      (inputs (list qtbase-5 qttools-5 poppler-qt5))
+      (native-inputs (list pkg-config extra-cmake-modules))
+      (home-page "http://www.qtrac.eu/diffpdf-foss.html")
+      (synopsis "Compare two PDF files")
+      (description
+       "@command{diffpdf} lets you compare PDF files, offering three
+comparison modes: words, characters, and appearance.")
+      (license license:gpl2))))
+
 (define-public extractpdfmark
   (package
     (name "extractpdfmark")