summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm30
-rw-r--r--gnu/packages/syncthing.scm29
2 files changed, 30 insertions, 29 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0e0ad5804a..1e54033c76 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3525,6 +3525,36 @@ well as a program to generate applications and command files.")
 storage system.")
     (license license:bsd-2)))
 
+(define-public go-github-com-thejerf-suture
+  (package
+    (name "go-github-com-thejerf-suture")
+    (version "3.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/thejerf/suture")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "03bdrl78jfwk0kw40lj63ga9cxhgccgss8yi9lp5j0m0ml7921gh"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/thejerf/suture"))
+    (home-page "https://github.com/thejerf/suture")
+    (synopsis "Supervisor trees for Go")
+    (description "Suture provides Erlang-ish supervisor trees for Go.
+\"Supervisor trees\" -> \"sutree\" -> \"suture\" -> holds your code together
+when it's trying to die.
+
+It is intended to deal gracefully with the real failure cases that can occur
+with supervision trees (such as burning all your CPU time endlessly restarting
+dead services), while also making no unnecessary demands on the \"service\"
+code, and providing hooks to perform adequate logging with in a production
+environment")
+    (license license:expat)))
+
 (define-public go-github-com-tidwall-gjson
   (package
     (name "go-github-com-tidwall-gjson")
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index b9cd50740d..50242470c4 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -280,35 +280,6 @@ structs in the Go programming language.")
     (home-page "https://github.com/d4l3k/messagediff")
     (license expat)))
 
-(define-public go-github-com-thejerf-suture
-  (package
-    (name "go-github-com-thejerf-suture")
-    (version "3.0.2")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/thejerf/suture")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "03bdrl78jfwk0kw40lj63ga9cxhgccgss8yi9lp5j0m0ml7921gh"))))
-    (build-system go-build-system)
-    (arguments
-     `(#:import-path "github.com/thejerf/suture"))
-    (synopsis "Supervisor trees for Go")
-    (description "Suture provides Erlang-ish supervisor trees for Go.
-\"Supervisor trees\" -> \"sutree\" -> \"suture\" -> holds your code together
-when it's trying to die.
-
-It is intended to deal gracefully with the real failure cases that can occur
-with supervision trees (such as burning all your CPU time endlessly restarting
-dead services), while also making no unnecessary demands on the \"service\"
-code, and providing hooks to perform adequate logging with in a production
-environment")
-    (home-page "https://github.com/thejerf/suture")
-    (license expat)))
-
 (define-public go-github-com-vitrun-qart
   (let ((commit "bf64b92db6b05651d6c25a3dabf2d543b360c0aa")
         (revision "0"))