summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gl.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 14b033e305..4a23cf4042 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -243,7 +243,11 @@ also known as DXTn or DXTC) for Mesa.")
         ("python" ,python-2)))
     (arguments
      `(#:configure-flags
-       '("--with-gallium-drivers=i915,r300,r600,svga,swrast,nouveau,virgl"
+       '(,@(match (%current-system)
+             ((or "armhf-linux" "aarch64-linux")
+              '("--with-galluim-drivers=freedreno,nouveau,r300,r600,svga,svrast,vc4,virgl"))
+             (_
+              '("--with-gallium-drivers=i915,nouveau,r300,r600,svga,swrast,virgl")))
          ;; Enable various optional features.  TODO: opencl requires libclc,
          ;; omx requires libomxil-bellagio
          "--with-egl-platforms=x11,drm,wayland"