summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index ced7e90575..f57fedb379 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -172,6 +172,12 @@ developers using C++ or QML, a CSS & JavaScript like language.")
             (let ((out (assoc-ref outputs "out")))
               (substitute* '("configure")
                            (("/bin/pwd") (which "pwd")))
+              ;; Explicitly link with icui18n, which is dlopened by
+              ;; QtCore.so. The LDFLAGS are in fact added to other flags
+              ;; determined by the configure phase.
+              ;; According to the nix recipe, this may be necessary for
+              ;; further libraries (cups, gtk-x11-2.0, libgdk-x11-2.0).
+              (setenv "LDFLAGS" "-licui18n")
               ;; do not pass "--enable-fast-install", which makes the
               ;; configure process fail
               (zero? (system*