summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/guile.scm7
-rw-r--r--gnu/packages/patches/guile-3.0-crash.patch17
3 files changed, 2 insertions, 23 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index fa578749cf..b0b72e6349 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1002,7 +1002,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/gspell-dash-test.patch			\
   %D%/packages/patches/guile-1.8-cpp-4.5.patch			\
   %D%/packages/patches/guile-2.2-skip-oom-test.patch            \
-  %D%/packages/patches/guile-3.0-crash.patch			\
   %D%/packages/patches/guile-default-utf8.patch			\
   %D%/packages/patches/guile-gdbm-ffi-support-gdbm-1.14.patch	\
   %D%/packages/patches/guile-linux-syscalls.patch		\
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index c87728f432..0efee2d86a 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -269,17 +269,14 @@ without requiring the source code to be rewritten.")
   (package
     (inherit guile-2.2)
     (name "guile")
-    (version "3.0.1")
+    (version "3.0.2")
     (source (origin
               (inherit (package-source guile-2.2))
               (uri (string-append "mirror://gnu/guile/guile-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "1jakps3127h8g69ixgb4zwc8v2g29dmwql1vi3pwg30kzp8fm5nn"))
-              (patches
-               (append (search-patches "guile-3.0-crash.patch")
-                       (origin-patches (package-source guile-2.2))))))
+                "12lziar4j27j9whqp2n18427q45y9ghq7gdd8lqhmj1k0lr7vi2k"))))
     (native-search-paths
      (list (search-path-specification
             (variable "GUILE_LOAD_PATH")
diff --git a/gnu/packages/patches/guile-3.0-crash.patch b/gnu/packages/patches/guile-3.0-crash.patch
deleted file mode 100644
index 510834ab57..0000000000
--- a/gnu/packages/patches/guile-3.0-crash.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Fix crash due to: <https://issues.guix.gnu.org/issue/39266>.
-
-diff --git a/libguile/struct.c b/libguile/struct.c
-index 3dbcc71d4..ddcbe46d2 100644
---- a/libguile/struct.c
-+++ b/libguile/struct.c
-@@ -139,7 +139,9 @@ set_vtable_access_fields (SCM vtable)
-   nfields = len / 2;
- 
-   bitmask_size = (nfields + 31U) / 32U;
--  unboxed_fields = scm_gc_malloc_pointerless (bitmask_size, "unboxed fields");
-+  unboxed_fields =
-+    scm_gc_malloc_pointerless (bitmask_size * sizeof (*unboxed_fields),
-+                               "unboxed fields");
-   memset (unboxed_fields, 0, bitmask_size * sizeof(*unboxed_fields));
- 
-   /* Update FLAGS according to LAYOUT.  */