summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e7f854d636..487dd8dcd2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -880,22 +880,22 @@ designed to be accessed through the MIME functions in GnomeVFS.")
                                   (version-major+minor version)  "/"
                                   name "-" version ".tar.bz2"))
               (sha256
-               (base32 "1ajg8jb8k3snxc7rrgczlh8daxkjidmcv3zr9w809sq4p2sn9pk2"))))
+               (base32
+                "1ajg8jb8k3snxc7rrgczlh8daxkjidmcv3zr9w809sq4p2sn9pk2"))))
     (build-system gnu-build-system)
     (arguments
-     ;; The programmer kindly gives us a hook to turn off deprecation warnings ...
-     `(#:configure-flags '("DISABLE_DEPRECATED_CFLAGS=-DGLIB_DISABLE_DEPRECATION_WARNINGS")
-                         ;; ... which they then completly ignore !!
-                         #:phases
-                         (alist-cons-before
-                          'configure 'ignore-deprecations
-                          (lambda _
-                            (begin
-                              (substitute* "libgnomevfs/Makefile.in"
-                                (("-DG_DISABLE_DEPRECATED") "-DGLIB_DISABLE_DEPRECATION_WARNINGS"))
-                              (substitute* "daemon/Makefile.in"
-                                (("-DG_DISABLE_DEPRECATED") "-DGLIB_DISABLE_DEPRECATION_WARNINGS"))))
-                          %standard-phases)))
+     `(;; XXX The 'test-async-cancel' test often fails.
+       #:make-flags '("XFAIL_TESTS=test-async-cancel")
+
+       #:phases
+       (alist-cons-before
+        'configure 'ignore-deprecations
+        (lambda _
+          (substitute* '("libgnomevfs/Makefile.in"
+                         "daemon/Makefile.in")
+            (("-DG_DISABLE_DEPRECATED") "-DGLIB_DISABLE_DEPRECATION_WARNINGS"))
+          #t)
+        %standard-phases)))
     (inputs `(("glib" ,glib)
               ("libxml2" ,libxml2)
               ("dbus-glib" ,dbus-glib)
@@ -909,9 +909,10 @@ designed to be accessed through the MIME functions in GnomeVFS.")
        ("pkg-config" ,pkg-config)))
     (home-page "https://developer.gnome.org/gnome-vfs/")
     (synopsis "Access files and folders in GNOME applications")
-    (description  "GnomeVFS is the core library used to access files and
-folders in GNOME applications.  It provides a file system abstraction which
-allows applications to access local and remote files with a single consistent API.")
+    (description
+     "GnomeVFS is the core library used to access files and folders in GNOME
+applications.  It provides a file system abstraction which allows applications
+to access local and remote files with a single consistent API.")
     (license license:lgpl2.0+)))