summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gstreamer.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 71f8e3453a..2be9f6b314 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2015, 2016 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2015, 2018 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016, 2017, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2022-2024 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017, 2023 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -800,19 +800,17 @@ model to base your own plug-in on, here it is.")
                   ;; The 'elements_curlhttpsrc' test sometimes times out.
                   ((".*'elements/curlhttpsrc\\.c'.*") "")
 
-                  ;; This test is flaky on at least some architectures.
-                  ;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244
+                  ;; TODO: Figure out why this test fails on riscv64-linux.
                   #$@(if (target-riscv64?)
-                       `((("'elements/camerabin\\.c'\\].*],")
-                          "'elements/camerabin.c'], true, ],")
-                         (("'elements/viewfinderbin\\.c'\\].*],")
-                          "'elements/viewfinderbin.c'], true, ],"))
-                       '())
+                         `((("'elements/viewfinderbin\\.c'\\].*],")
+                            "'elements/viewfinderbin.c'], true, ],"))
+                         '())
 
-                  ;; This substitution is no longer effective and can be removed.
+                  ;; This test is flaky on at least some architectures.
+                  ;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244
                   #$@(if (member (%current-system)
-                                 '("i686-linux" "aarch64-linux" "riscv64-linux"))
-                         `((("'elements/camerabin\\.c'\\]\\],")
+                                 '("aarch64-linux" "riscv64-linux"))
+                         `((("'elements/camerabin\\.c'\\].*],")
                             "'elements/camerabin.c'], true, ],"))
                          '())