summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/compression.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 1c1276dc82..ea3d72c011 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1269,14 +1269,15 @@ for most inputs, but the resulting compressed files are anywhere from 20% to
     (name "bitshuffle-for-snappy")
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           (lambda* (#:key outputs #:allow-other-keys)
-             (with-output-to-file "Makefile"
-               (lambda _
-                 (format #t "\
+     (substitute-keyword-arguments (package-arguments bitshuffle)
+       ((#:tests? _ #f) #f)
+       ((#:phases phases)
+        `(modify-phases %standard-phases
+           (replace 'configure
+             (lambda* (#:key outputs #:allow-other-keys)
+               (with-output-to-file "Makefile"
+                 (lambda _
+                   (format #t "\
 libbitshuffle.so: src/bitshuffle.o src/bitshuffle_core.o src/iochain.o lz4/lz4.o
 \tgcc -O3 -ffast-math -std=c99 -o $@ -shared -fPIC $^
 
@@ -1296,7 +1297,7 @@ install: libbitshuffle.so
 \tinstall -m644 src/iochain.h $(INCLUDEDIR)
 \tinstall -m644 lz4/lz4.h $(INCLUDEDIR)
 " (assoc-ref outputs "out"))))
-             #t)))))
+               #t))))))
     (inputs '())
     (native-inputs '())))