summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/autotools.scm2
-rw-r--r--gnu/packages/commencement.scm2
-rw-r--r--gnu/packages/guile.scm6
3 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 118f25ba09..006a9e202b 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -209,7 +209,7 @@ files with a system-specific shebang."
     (inputs `(("guile"
                ;; XXX: Kludge to hide the circular dependency.
                ,(module-ref (resolve-interface '(gnu packages guile))
-                            'guile-3.0/fixed))
+                            'guile-3.0/pinned))
               ("autoconf" ,autoconf)
               ("bash" ,bash-minimal)))
     (arguments
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index b4566b41cc..7335aedec2 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3623,7 +3623,7 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
   ;; This package must be public because other modules refer to it.  However,
   ;; mark it as hidden so that 'fold-packages' ignores it.
   (with-boot4 (hidden-package
-               (package-with-bootstrap-guile guile-3.0/fixed))))
+               (package-with-bootstrap-guile guile-3.0/pinned))))
 
 (define-public glibc-utf8-locales-final
   ;; Now that we have GUILE-FINAL, build the UTF-8 locales.  They are needed
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index edf289e574..2fd9b711ce 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -419,7 +419,11 @@ without requiring the source code to be rewritten.")
                         "GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives -Ocps\n")))))
                '())))))))
 
-(define-public guile-3.0/fixed
+;;; The symbol guile-3.0/fixed should be used when guile-3.0 needs fixes
+;;; (security or else) and this deprecation could be removed.
+(define-deprecated/public-alias guile-3.0/fixed guile-3.0/pinned)
+
+(define-public guile-3.0/pinned
   ;; A package of Guile that's rarely changed.  It is the one used in the
   ;; `base' module, and thus changing it entails a full rebuild.
   (package