summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patool.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/patool.scm b/gnu/packages/patool.scm
index 31dfd994b1..5cd05af97c 100644
--- a/gnu/packages/patool.scm
+++ b/gnu/packages/patool.scm
@@ -20,7 +20,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix git-download)
   #:use-module (guix packages)
-  #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject)
   #:use-module (gnu packages)
   #:use-module (gnu packages backup)
   #:use-module (gnu packages cdrom)
@@ -46,13 +46,19 @@
        (sha256
         (base32
          "0zgvgx9549rvb57rgkpjalydz46k71gibfs6ab3b3sy439s0ay4h"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (replace 'check
-                    (lambda* (#:key tests? #:allow-other-keys)
-                      (when tests?
-                        (invoke "pytest")))))))
+     (list
+      #:test-flags
+      '(list "-k" (string-append
+                   ;; Disable failing tests.
+                   "not test_mime_file_compress"
+                   " and not test_mime_file_gzip"
+                   " and not test_mime_file_lzip"
+                   " and not test_bsdtar_gz_file"
+                   " and not test_py_tarfile_gz_file"
+                   " and not test_tar_gz_file"
+                   " and not test_tar_lzip_file"))))
     (native-inputs
      (list bzip2
            cabextract