summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm6
-rw-r--r--gnu/packages/gcc.scm6
2 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 7ca7ec74c6..a5c6a70603 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -756,7 +756,11 @@ identifier SYSTEM."
                ;; Call it differently so that the builder can check whether
                ;; the "libc" input is #f.
                ("libc-native" ,@(assoc-ref %boot0-inputs "libc"))
-               ,@(alist-delete "libc" %boot0-inputs))))))
+               ,@(alist-delete "libc" %boot0-inputs)))
+
+     ;; No need for Texinfo at this stage.
+     (native-inputs (alist-delete "texinfo"
+                                  (package-native-inputs gcc-4.7))))))
 
 (define linux-libre-headers-boot0
   (package-with-bootstrap-guile
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index bba35901a2..f8caf4c7f6 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -23,6 +23,7 @@
   #:use-module (gnu packages bootstrap)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages multiprecision)
+  #:use-module (gnu packages texinfo)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
@@ -104,6 +105,10 @@ where the OS part is overloaded to denote a specific ABI---into GCC
                 ("cloog" ,cloog)
                 ("libelf" ,libelf)
                 ("zlib" ,zlib)))
+
+      ;; GCC is one of the few packages that doesn't ship .info files.
+      (native-inputs `(("texinfo" ,texinfo)))
+
       (arguments
        `(#:out-of-source? #t
          #:strip-binaries? ,stripped?
@@ -199,7 +204,6 @@ used in the GNU system including the GNU/Linux variant.")
       (home-page "http://gcc.gnu.org/"))))
 
 (define-public gcc-4.8
-  ;; FIXME: Move to gcc.scm when Binutils is updated.
   (package (inherit gcc-4.7)
     (version "4.8.0")
     (source (origin