summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cdrom.scm2
-rw-r--r--gnu/packages/help2man.scm53
-rw-r--r--gnu/packages/man.scm31
-rw-r--r--gnu/packages/zile.scm2
4 files changed, 33 insertions, 55 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 11bfa2f7cf..e520312164 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -27,7 +27,7 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gtk)
-  #:use-module (gnu packages help2man)
+  #:use-module (gnu packages man)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages elf)
   #:use-module (gnu packages pkg-config)
diff --git a/gnu/packages/help2man.scm b/gnu/packages/help2man.scm
deleted file mode 100644
index 9f3af7c9f5..0000000000
--- a/gnu/packages/help2man.scm
+++ /dev/null
@@ -1,53 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages help2man)
-  #:use-module (guix licenses)
-  #:use-module (guix download)
-  #:use-module (guix packages)
-  #:use-module (guix build-system gnu)
-  #:use-module (gnu packages perl))
-
-(define-public help2man
-  (package
-    (name "help2man")
-    (version "1.45.1")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://gnu/help2man/help2man-"
-                          version ".tar.xz"))
-      (sha256
-       (base32
-        "1hk7ciqinq7djdb7s94y3jxh06rp8i93bpjmg4r40cniws8wf3y7"))))
-    (build-system gnu-build-system)
-    (arguments `(;; There's no `check' target.
-                 #:tests? #f))
-    (inputs
-     `(("perl" ,perl)
-       ;; TODO: Add these optional dependencies.
-       ;; ("perl-LocaleGettext" ,perl-LocaleGettext)
-       ;; ("gettext" ,gettext)
-       ))
-    (home-page "http://www.gnu.org/software/help2man/")
-    (synopsis "Automatically generate man pages from program --help")
-    (description
-     "GNU help2man is a program that converts the output of standard
-\"--help\" and \"--version\" command-line arguments into a manual page
-automatically.")
-    (license gpl3+)))
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index db13fc14a7..9be408a3d1 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -1,4 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -26,6 +27,7 @@
   #:use-module (gnu packages groff)
   #:use-module (gnu packages less)
   #:use-module (gnu packages lynx)
+  #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config))
 
 (define-public libpipeline
@@ -107,3 +109,32 @@ a flexible and convenient way.")
 accessed using the man command.  It uses a Berkeley DB database in place of
 the traditional flat-text whatis databases.")
     (license gpl2+)))
+
+(define-public help2man
+  (package
+    (name "help2man")
+    (version "1.45.1")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/help2man/help2man-"
+                          version ".tar.xz"))
+      (sha256
+       (base32
+        "1hk7ciqinq7djdb7s94y3jxh06rp8i93bpjmg4r40cniws8wf3y7"))))
+    (build-system gnu-build-system)
+    (arguments `(;; There's no `check' target.
+                 #:tests? #f))
+    (inputs
+     `(("perl" ,perl)
+       ;; TODO: Add these optional dependencies.
+       ;; ("perl-LocaleGettext" ,perl-LocaleGettext)
+       ;; ("gettext" ,gnu-gettext)
+       ))
+    (home-page "http://www.gnu.org/software/help2man/")
+    (synopsis "Automatically generate man pages from program --help")
+    (description
+     "GNU help2man is a program that converts the output of standard
+\"--help\" and \"--version\" command-line arguments into a manual page
+automatically.")
+    (license gpl3+)))
diff --git a/gnu/packages/zile.scm b/gnu/packages/zile.scm
index 96e05bc65a..4f198e4849 100644
--- a/gnu/packages/zile.scm
+++ b/gnu/packages/zile.scm
@@ -24,7 +24,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages perl)
-  #:use-module (gnu packages help2man)
+  #:use-module (gnu packages man)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages bash)
   #:use-module (gnu packages pkg-config))